东方财富自定义换手率副图指标(QDHSL)

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/hjpqindong/article/details/80383500

注意

使用前需添加一个变量ZQ,取值为:2、120、2

换手率:100*VOL/CAPITAL,VOLSTICK;
量比:(VOL/2400)/((REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4)+REF(VOL,5))/(5*2400)),NODRAW;
MH5:MA(HSL,5)*2,dotline,COLORWHITE;
MH10:MA(HSL,10)*2,COLORYELLOW;
MH20:MA(HSL,20)*2,LINETHICK2,COLORMAGENTA;

{标注板块}
DQBLK:=STRCAT('【地区:',DQBLOCK,'】');
GNBLK:=STRCAT('【概念:',GNBLOCK,'】');
HYBLK:=STRCAT('【行业:',HYBLOCK,'】');
SBL:=STRCAT(HYBLK,'  ',GNBLK,'  ',DQBLK,'  【换手率:',CON2STR(换手率,2),'】','  【量比:',CON2STR(量比,2),'】');
DRAWTEXT_FIX(ISLASTBAR,0,0.02,0,SBL),COLORWHITE;

{标注财务指标}
BGQS:=STRCAT('【第',CON2STR(FINANCE(37),0),'期财报】');
LDFZ:=STRCAT('流动负债',CON2STR(FINANCE(15)/10000,1),'亿');
ZZC:=STRCAT('总资产',CON2STR(FINANCE(10)/10000,1),'亿 ');
FZL:=STRCAT(CON2STR((FINANCE(15)/FINANCE(10))*100,1),'%');
ZYLR:=STRCAT('主营利润',CON2STR(FINANCE(21),0),'万 ');
MGSY:=STRCAT('每股收益',CON2STR(FINANCE(33),2),'元 ');
MGJZC:=STRCAT('每股净值',CON2STR(FINANCE(34),2),'元 ');
MGWFP:=STRCAT('每股未分配',CON2STR(FINANCE(32),2),'元 ');
LRZE:=STRCAT('总利润',CON2STR(FINANCE(28),0),'万 ');
JLR:=STRCAT('净利润',CON2STR(FINANCE(30),0),'万 ');
{ZXJL:=STRCAT('总现金流',CON2STR(FINANCE(26),0),'万 ');0,无效函数}
CaiWu:=STRCAT(BGQS,'  ',MGSY,'  ',MGJZC,'  ',MGWFP,'  ',ZYLR,'  ',LRZE,'  ',JLR,'  ',ZZC,'  ',LDFZ,'(',FZL,')');
DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,CaiWu),COLORGREEN;

HHV_HSL:=HHV(换手率,ZQ);
H3:if(HHV_HSL<3 OR HHV_HSL>=3,3,DRAWNULL),dotline,COLORWHITE;
H6:if(HHV_HSL>=6 OR (HHV_HSL>3 AND HHV_HSL<6),6,DRAWNULL),dotline,COLORYELLOW;
H10:if(HHV_HSL>=10 OR (HHV_HSL>6 AND HHV_HSL<10),10,DRAWNULL),dotline,COLORGREEN;
H15:if(HHV_HSL>=15 OR (HHV_HSL>10 AND HHV_HSL<15),15,DRAWNULL),dotline,COLORMAGENTA;
H20:if(HHV_HSL>=20 OR (HHV_HSL>15 AND HHV_HSL<20),20,DRAWNULL),dotline,COLORRED;
H25:if(HHV_HSL>=25 OR (HHV_HSL>20 AND HHV_HSL<25),25,DRAWNULL),dotline,COLORRED;
展开阅读全文

没有更多推荐了,返回首页