HDU5631并查集检验图连通

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5631


Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 562    Accepted Submission(s): 258


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number  T(T30) ——The number of the testcases.

For each testcase, the first line contains a number  n(n100) .

Then n+1 lines follow. Each line contains two numbers  u,v  , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 

问题描述
众所周知,萌萌哒六花不擅长数学,所以勇太给了她一些数学问题做练习,其中有一道是这样的:

给出一张 nn 个点 n+1n+1 条边的无向图,你可以选择一些边(至少一条)删除。

现在勇太想知道有多少种方案使得删除之后图依然联通。

当然,这个问题对于萌萌哒六花来说实在是太难了,你可以帮帮她吗?
输入描述
第一行一个整数表示数据组数 T(T \leq 30)T(T30)。

每组数据的第一行是一个整数 n(n \leq 100)n(n100)。

接下来 n+1n+1 行每行两个整数 u,vu,v 表示图中的一条边。
这个题目,枚举加并查集就可以了,因为有N+1条边,图连通最少的边是n-1条,所以最多只能删两条,那么直接枚举,再用并查集检验图是否连通就好了,虽然我写的代码有点长,但是很大部分是一样的,不要慌。

#include <stdio.h>
#include <string.h>
struct N
{
    int l,r;
}st[110];
int num[1100];
int find(int x)<span style="white-space:pre">		</span>//并查集
{
    if ( x != num[x])
    {
        num[x] = find(num[x]);
    }
    return num[x];
}
void unio(int x , int y)<span style="white-space:pre">	</span>//连通
{
    if ( find(x) == find(y) )
    {
        return ;
    }
    else 
    {
        num[find(x)] = num[find(y)];
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while (t-- )
    {
        int n;
        scanf("%d",&n );
        for (int i = 0 ; i <= n ; i++ )
        {
            scanf("%d %d",&st[i].l,&st[i].r);
        }
        __int64 res = 0;
        for (int i = 0 ; i <= n ; i ++ )<span style="white-space:pre">	</span>//删除一条边
        {
            for (int j = 0 ; j <= n ; j++ )<span style="white-space:pre">	</span>//初始化
            {
                num[j] = j;
            }
            for (int j = 0 ; j <= n ; j++ )
            {
                if (j == i)<span style="white-space:pre">		</span>//删除i边
                {
                    continue;
                }
                unio(st[j].l,st[j].r);
            }
            int flag = 0;
            for (int j = 2 ; j <= n ; j++ )<span style="white-space:pre">		</span>//检验
            {
                if (find(num[j]) != find(num[j-1]))
                {
                    flag = 1;
                    break;
                }
            }
            if (flag == 0)
            {
                res++;
            }
        }
        for (int i = 0 ; i <= n ; i ++ )<span style="white-space:pre">		</span>//删除两条边
        {
            for (int j = i + 1 ; j <= n ; j++ )<span style="white-space:pre">		</span>//删除i边和j 边
            {
                for (int k = 0 ; k <= n ; k++ )<span style="white-space:pre">		</span>//初始化
                {
                    num[k] = k;
                }
                for (int k = 0 ; k <= n ; k++ )
                {
                    if (k == i || k == j)
                    {
                        continue;
                    }
                   unio(st[k].l,st[k].r);
                } 
                int flag = 0;
                for (int k = 2 ; k <= n ; k++ )<span style="white-space:pre">		</span>//检验
                {
                    if (find(num[k]) != find(num[k-1]))
                    {
                        flag = 1;
                        break;
                    }
                }
                if (flag == 0)
                {
                    res++;
                }
            }
        }
        printf("%I64d\n",res);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值