android sdk版本版本与ADT版本不兼容的处理办法

分析原因

android sdk版本更新到了最新的21.0.0 ,而之前我安装的是16.0.0的版本,在更新到最新的API后android-sdk-windows/tools/lib下的plugin.pro文件内容变为# begin plugin.prop plugin.version=21.0.0# end plugin.prop而Eclipse开发环境的在查看该文件时,查找到plugin.version=21.0.0,认为当前的sdk需要21.0.0版本以上的插件,但我们还是以前旧的插件。ADT插件的版本还是16.0.0的,所以导致出现了上述问题。

解决方法有如下两种

1、修改android-sdk-windows/tools/lib下的plugin.pro文件,用记事本打开,将plugin.version的版本信息改为旧版本的版本号,诸如提示的16.0.0. 修改为plugin.version=16.0.0,保存,重启Eclipse即可。

2、将ADT插件也更新到最新的版本。"Help-->Install New Software..."在work with中找到你的ADT插件项,然后再更新即可。完全安装的方法可以查看在Windows下Android开发环境的搭建方法中的ADT的添加方法。

上述两种方法均可解决更新API后出现的Please update ADT to the latest version的问题,如果有其他问题欢迎一起讨论。

没有更多推荐了,返回首页