HDU 2112 Today Dijkstra

map确实是个强大的东西。。

HDU Today

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 28595    Accepted Submission(s): 6931
Problem Description
经过锦囊相助,海东集团终于度过了危机,从此,HDU的发展就一直顺风顺水,到了2050年,集团已经相当规模了,据说进入了钱江肉丝经济开发区500强。这时候,XHD夫妇也退居了二线,并在风景秀美的诸暨市浬浦镇陶姚村买了个房子,开始安度晚年了。 这样住了一段时间,徐总对当地的交通还是不太了解。有时很郁闷,想去一个地方又不知道应该乘什么公交车,在什么地方转车,在什么地方下车(其实徐总自己有车,却一定要与民同乐,这就是徐总的性格)。 徐总经常会问蹩脚的英文问路:“Can you help me?”。看着他那迷茫而又无助的眼神,热心的你能帮帮他吗? 请帮助他用最短的时间到达目的地(假设每一路公交车都只在起点站和终点站停,而且随时都会开)。
 
Input
输入数据有多组,每组的第一行是公交车的总数N(0<=N<=10000); 第二行有徐总的所在地start,他的目的地end; 接着有n行,每行有站名s,站名e,以及从s到e的时间整数t(0<t<100)(每个地名是一个长度不超过30的字符串)。 note:一组数据中地名数不会超过150个。 如果N==-1,表示输入结束。
 
Output
如果徐总能到达目的地,输出最短的时间;否则,输出“-1”。
 
Sample Input
   
   
6 xiasha westlake xiasha station 60 xiasha ShoppingCenterofHangZhou 30 station westlake 20 ShoppingCenterofHangZhou supermarket 10 xiasha supermarket 50 supermarket westlake 10 -1
 

Sample Output
   
   
50 Hint: The best route is: xiasha->ShoppingCenterofHangZhou->supermarket->westlake 虽然偶尔会迷路,但是因为有了你的帮助 **和**从此还是过上了幸福的生活。 ――全剧终――
#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int Max = 155;
int dis[Max], res[Max][Max];
bool visit[Max];
void Dijkstra(int end)
{
	int temp,k;
	memset(visit,false,sizeof(visit));
	for(int i = 1; i <= end; ++i)
	{
		dis[i] = res[1][i];
	}
	dis[1] = 0;
	visit[1] = 1;
	for(int i =1; i <= end; ++i)
	{
		temp = INF;
		for(int j = 1; j <= end; ++j)
		{
			if(!visit[j] && temp > dis[j])
			{
				temp = dis[k = j];
			}
		 } 
		 if(temp == INF)
		 break;
		 visit[k] = 1;
		 for(int j = 1; j <= end; ++j)
		 {
		 	if(!visit[j] && dis[j] > dis[k] + res[k][j])
		 	{
		 		dis[j] = dis[k] + res[k][j];
			 }
		 }
	}
}
int main()
{
	int num,count;
	char s[32],e[32];
	bool flag;
	char str[32],str1[32];
	int cost;
	map<string,int>car;
	while(scanf("%d",&num) != EOF && num != -1)
	{
		flag = 0;
		car.clear();
		memset(res,INF,sizeof(res));
		count = 3;
		scanf("%s%s",s,e);
		if(strcmp(s,e) == 0)
		{
			flag = 1;
		}
		car[s] = 1;
		car[e] = 2;
		for(int i = 1; i <= num; i++)
		{
			scanf("%s%s%d",str,str1,&cost);
			if(!car[str])
			{
				car[str] = count++;
			 } 
			 if(!car[str1])
			 {
			 	car[str1] = count++;
			 }
			 if(cost < res[car[str]][car[str1]])
			 {
			 	res[car[str]][car[str1]] = res[car[str1]][car[str]] = cost;
			 }
		
		}
		 if(flag)
		 {
		 	printf("0\n");
		 	continue;
		 }
		 Dijkstra(count-1);
		 if(dis[2] == INF)
		 {
		 	printf("-1\n");
		 }
		 else
		 printf("%d\n",dis[2]);	
	 } 
	 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值