HDU-4287 Intelligent IME (Trie 字典树 入门题)

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5333    Accepted Submission(s): 2509


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
  
  
1 3 5 46 64448 74 go in night might gn
 

Sample Output
  
  
3 2 0
 
#include <bits/stdc++.h>
using namespace std;
#define maxn 300000
int ch[maxn][12], st[maxn], tot, ans[5005];
void insert(char s[], int id){
	int n = strlen(s), k = 0, y;
	for(int i = 0; i < n; ++i){
		y = s[i] - '0';
		if(ch[k][y] == 0){
			ch[k][y] = ++tot;
			for(int j = 0; j < 10; ++j){
				ch[ch[k][y]][j] = 0;
			}
		}
		k = ch[k][y];
	}
	st[k] = id;
}
int query(char s[]){
	int k = 0, y, n = strlen(s);
	for(int i = 0; i < n; ++i){
		y = s[i] - 'a';
		if(y <= 17) y = y / 3 + 2;
		else if(y == 18) y = 7;
		else if(y <= 21) y = 8;
		else y = 9;
		if(ch[k][y] == 0) return 0;
		k = ch[k][y];
	}
	return st[k];
}
int main(){
	int T, n, m;
	char s[10];
	scanf("%d", &T);
	while(T--){
		memset(ans, 0, sizeof(ans));
		memset(st, 0, sizeof(st));
		scanf("%d %d", &n, &m);
		tot = 0;
		for(int i = 0; i < 10; ++i){
			ch[0][i] = 0;
		}
		for(int i = 1; i <= n; ++i){
			scanf("%s", s);
			insert(s, i);
		}
		for(int i = 1; i <= m; ++i){
			scanf("%s", s);
			ans[query(s)]++;
		}
		for(int i = 1; i <= n; ++i){
			printf("%d\n", ans[i]);
		}
	}
	return 0;
}

/*
题意:电话上每个数字都对应一些英文字母。现在有5000个数字串,
5000个英文字母串。问每个数字串有多少个匹配的英文字母串。

思路:对所有数字串建Trie,对于第i个数字串,在Trie的串尾标记
一下数字串的id,用来统计答案。询问时,在数字串建的trie中遍历
字母串时只需将字母转换成对应的数字即可,末尾统计答案。
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值