ZOJ-3623 Battle Ships (完全背包 应用题)

Battle Ships

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input
1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output
2
4
5


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[366];
int main(){
	int n, l, t, c;
	while(scanf("%d %d", &n, &l) != EOF){
		memset(dp, 0, sizeof(dp));
		for(int i = 1; i <= n; ++i){
			scanf("%d %d", &t, &c);
			for(int j = t; j <= 366; ++j){
				dp[j] = max(dp[j], dp[j - t] + c * (j - t));
			}
		}
		int ans;
		for(int i = 0; i <= 366; ++i){
			if(dp[i] >= l){
				ans = i;
				break;
			}
		}
		printf("%d\n", ans);
	}
}

/*
题意:有一个防守塔有L的血,现在可以建造一些攻击船,每个船有建造时间,建造完成后有每秒都会对塔造成
一定的伤害量,问最少需要多少时间可以把防守塔的血量打完。

思路:
设dp[j]表示前j秒造成的最大伤害,然后对每一艘船都跑一次背包,实际上对于每艘船,一定是从第一秒开始造,
一个接一个地不停造,dp[j] = max(dp[j], dp[j - t] + c * (j - t)),这样可能好理解一点:c * (j - t)是第一
艘船的贡献,第一艘船造完后还剩j - t的时间,除去第一艘船,j - t时间可以造成的最大伤害就是dp[j - t],再加上
第一艘船的伤害c * (j - t)即可。对于后面的不同种类的船,就在之前跑过的dp上再跑背包就行了。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值