POJ-2104 K-th Number (主席树 不带修改区间第k大)

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 61874 Accepted: 21744
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.


#include <stdio.h>
#include <algorithm> 
using namespace std;    
const int maxn = 100010;  
const int INF = 1 << 30;
int a[maxn], b[maxn], rt[maxn], tot;
struct tree{
	int sum, lson, rson;
}c[maxn << 5];
int newNode(int sum, int lson, int rson){
	int id = ++tot;
	c[id].sum = sum;
	c[id].lson = lson;
	c[id].rson = rson;
	return id;
}
void insert(int& rt, int pre, int pos, int l, int r){
	rt = newNode(c[pre].sum + 1, c[pre].lson, c[pre].rson);
	if(l == r) return;
	int mid = l + r >> 1;
	if(pos <= mid) insert(c[rt].lson, c[pre].lson, pos, l, mid);
	else insert(c[rt].rson, c[pre].rson, pos, mid + 1, r);
}
int query(int Lrt, int Rrt, int l, int r, int k){
	if(l == r) return l;
	int mid = l + r >> 1;
	int sum = c[c[Rrt].lson].sum - c[c[Lrt].lson].sum;
	if(k <= sum) return query(c[Lrt].lson, c[Rrt].lson, l, mid, k);
	else return query(c[Lrt].rson, c[Rrt].rson, mid + 1, r, k - sum);
}
int main(){
	int n, m, l, r, k, pos, num;
	while(scanf("%d %d", &n, &m) != EOF){
		tot = rt[0] = 0;
		for(int i = 1; i <= n; ++i){
			scanf("%d", &a[i]);
			b[i] = a[i];
		}
		sort(b + 1, b + 1 + n);
		num = unique(b + 1, b + 1 + n) - b - 1;
		for(int i = 1; i <= n; ++i){
			pos = lower_bound(b + 1, b + num + 1, a[i]) - b;
			insert(rt[i], rt[i - 1], pos, 1, num);
		}
		while(m--){
			scanf("%d %d %d", &l, &r, &k);
			pos = query(rt[l - 1], rt[r], 1, num, k);
			printf("%d\n", b[pos]);
		}
	}
}    
  
/*
题意:
1e5个数,5e4次询问,每次询问区间第k大。

思路:
将1e5个数离散化后映射到值域线段树上,这样线段树可以类似于平衡树,对于单次询问
我们可以通过左右儿子的sz大小来找第k大的标号。对于多次询问我们需要用到主席树,记录
历史的某个时刻线段树上的sz。
我们按照数字出现的顺序建n棵线段树,对于没有修改到的结点,我们直接连到上一棵的结点,
对于修改到的,我们开辟新结点。这样对于区间[L,R],我们只需要看第L-1棵和第R棵线段树上
的sz来求第k大的标号即可。第L-1棵记录的是L之前出现的数字,减掉后就是在[L,R]之间出现的。
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ - 3616是一个题目,题目描述如下: 给定一组区间,每个区间有一个权重,要求选择一些区间,使得这些区间的右端点都小于等于k,并且权重之和最大。请问最大的权重和是多少? 解决这个问题的思路是使用动态规划。首先,将区间按照左端点从小到大进行排序。然后,定义一个dp数组,dp[i]表示右端点小于等于i的所有区间所能得到的最大权重。 接下来,遍历每一个区间,对于每个区间i,将dp[i]初始化为区间i的权重。然后,再遍历i之前的每个区间j,如果区间j的右端点小于等于k,并且区间j的权重加上区间i的权重大于dp[i],则更新dp[i]为dp[j]加上区间i的权重。 最后,遍历整个dp数组,找到最大的权重和,即为所求的答案。 下面是具体的代码实现: ```cpp #include <cstdio> #include <cstring> #include <algorithm> using namespace std; struct interval{ int start, end, weight; }; interval intervals[10005]; int dp[10005]; int n, m, k; bool compare(interval a, interval b) { if (a.start == b.start) { return a.end < b.end; } else { return a.start < b.start; } } int main() { while(~scanf("%d %d %d", &n, &m, &k)) { memset(dp, 0, sizeof dp); for (int i = 0; i < m; i++) { scanf("%d %d %d", &intervals[i].start, &intervals[i].end, &intervals[i].weight); } sort(intervals, intervals + m, compare); for (int i = 0; i < m; i++) { dp[i] = intervals[i].weight; for (int j = 0; j < i; j++) { if (intervals[j].end <= k && dp[j] + intervals[i].weight > dp[i]) { dp[i] = dp[j] + intervals[i].weight; } } } int maxWeight = 0; for (int i = 0; i < m; i++) { maxWeight = max(maxWeight, dp[i]); } printf("%d\n", maxWeight); } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值