poj 1469 COURSES 二分图最大匹配数

COURSES
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16542 Accepted: 6489

Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:


every student in the committee represents a different course (a student can represent a course if he/she visits that course)
each course has a representative in the committee

Input
Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES

NO

====================================================================================================

题目大意:现有N门课,P个学生,一门课可以有多个学生选,一个学生可以选多门课。问是不是每门课都至少有一个学生选。


解题思路:课与课之间没有关系,学生和学生之间没有关系,所以课和学生可以看成一个二分图。而我们想知道的就是这个二分图的最大匹配数是否不小于课的门数。

//Memory: 732K	Time: 500MS

#include<cstdio>
#include<vector>
using namespace std;
const int MAXN = 300;         //最多300门课
const int MAXP = 100;         //最多100个学生
vector<int> g[MAXN];          //用vector容器建邻接表
int P , N , linker[MAXP];
bool used[MAXP];
//匈牙利算法
bool dfs(int n)
{
    for( int i = 0 ; i < g[n].size() ; i++ )
    {
        int p = g[n][i];
        if( !used[p] )
        {
            used[p] = true;
            if( linker[p] == -1 || dfs(linker[p]) )
            {
                linker[p] = n;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res = 0;
    for( int i = 0 ; i < P ; i++ )
        linker[i] = -1;
    for( int i = 0 ; i < N ; i++ )
    {
        for( int j = 0 ; j < P ; j++ )
            used[j] = false;
        if( dfs(i) )
            res++;
        if( res == P )                     //如果找到的匹配数已经达到课程数
            break;                         //则一定能符合要求,不需要继续找
    }
    return res;
}

int main()
{
    int caseNum;
    scanf("%d" , &caseNum);
    while(caseNum--)
    {
        scanf("%d%d" , &P , &N);
        for( int i = 0 ; i < N ; i++ )     //初始化邻接表
            g[i].clear();
        for( int i = 0 ; i < P ; i++ )
        {
            int n;
            scanf("%d" , &n);
            while(n--)
            {
                int id;
                scanf("%d" , &id);
                g[id-1].push_back(i);      //输入的学生代号是从1开始的需要减1
            }
        }
        if( N < P || hungary() < P )       //如果学生数量没有课程多则一定不能满足要求
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值