HDU--杭电--Can you solve this equation?--二分

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6176    Accepted Submission(s): 2889


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 

 
题意就是看能不能找到一个 Y = 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6
有就输出,没有就输出那句英文

思路:题目说了从0到100中找,所以直接进行二分就是了
#include <iostream>
#include <stdio.h>
using namespace std;
double f(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main (void)
{
    int n;
    double y,first,last,d;
    cin>>n;
    while(cin>>y)
    {
        if(y<f(0)||y>f(100))	//不再范围内的直接特解掉
        {
            puts("No solution!");
            continue;
        }
        first=0;last=100;
        while(last-first>1e-8)	//二分查找
        {
            d=(last+first)/2;
            if(f(d)<y)
            {
                first=d+1e-8;	//1e-8就是-1/100000000,这是对付精度的
            }
            else
            {
                last=d-1e-8;
            }
        }printf("%.4lf\n",d);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值