POJ--2184--Cow Exhibition--01背包

21 篇文章 0 订阅

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9429 Accepted: 3624

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

原谅我的爱国,所以静不下心来看题,就直接在网上百度结题报告找题意,网上的基本都是模模糊糊,跟放屁一样。

题意:S和F分别是牛的两个属性,告诉你N头牛的这两个属性,然后要求你选出随意数量的牛,使得所有牛的S和F值加起来最大,同时所有牛的S值加起来不小于零,F值加起来也不小于零

解析:当作01背包来做的话就是把其中一个属性当作容量,这样下来,一定容量下得到的价值取最大就好了。

比如S当作容量,dp[X]的含义就成了:S值为X的时候F值最大量

但是S值有小于零的,这时我们考虑一下最小有多小就好做了,自己想吧!


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[222222];	//最小是-10W,那么把整个数组留10W以上的空间给负数就好了
int main (void)
{
    int n,m,i,j,k,l,a,b,x=111111;	//x标记0的位置
    int Max,Min;	//最大最小边界,方便遍历已经求过值的范围里的数据
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<222222;i++)
        {
            dp[i]=-999999;
        }
        Max=Min=x;
        dp[x]=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            if(a<0)
            {
                for(j=Min;j<=Max;j++)	//负的要从小到大,01背包
                {
                    if(dp[j+a]<dp[j]+b)
                    {
                        dp[j+a]=dp[j]+b;
                    }
                }
                Min+=a;
            }else
            {
                for(j=Max;j>=Min;j--)	//正的要从大到小,01背包
                {
                    if(dp[j+a]<dp[j]+b)
                    {
                        dp[j+a]=dp[j]+b;
                    }
                }
                Max+=a;
            }
        }
        l=0;
        k=x;
        while(k<=Max)	//找所有S值大于零的组合
        {
            if(dp[k]>=0&&l<k-x+dp[k])	//F也大于零
            {
                l=k-x+dp[k];
            }
            k++;
        }
        printf("%d\n",l);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值