POJ-2184 Cow Exhibition(01背包变形)

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10949 Accepted: 4344
Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input

  • Line 1: A single integer N, the number of cows

  • Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output

8
Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

看了别人博客才会写。01背包中体积出现负数怎么办?,整体加上100000,就行了,dp[100000]就和dp[0]一样,表示总体积为0.体积为负数的物品,要从小到大,和正数的物品反过来,因为如果和正数的物品一样的顺序,最大体积会增大,最大体积是不变的。

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
#include <math.h>

using namespace std;
#define MAX 99999999
int dp[200005];
int w[105];
int v[105];
int n;
int main()
{
    int ans;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<=200000;i++)
            dp[i]=-MAX;
        ans=0;
        for(int i=1;i<=n;i++)
            scanf("%d%d",&w[i],&v[i]);

        dp[100000]=0;
        for(int i=1;i<=n;i++)
        {
            if(w[i]<0&&v[i]<0)
                continue;
            if(w[i]>0)
            {
                for(int j=200000;j>=w[i];j--)
                {
                    if(dp[j-w[i]]!=-MAX)
                    {
                        dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
                    }
                }
            }
            else
            {
                for(int j=w[i];j<=200000+w[i];j++)
                {
                    if(dp[j-w[i]]!=MAX)
                    {
                        dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
                    }
                }
            }
        }
        ans=-MAX;
        for(int i=100000;i<=200000;i++)
        {
            if(dp[i]>=0)
                ans=max(ans,dp[i]+i-100000);
        }
        printf("%d\n",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228811.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值