POJ--2063--Investment--背包

21 篇文章 0 订阅

Investment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8733 Accepted: 2984

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
ValueAnnual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

题意:有多个存款方案,每个有两个属性值A和B,表示这个方案你要存A块钱,利息是B块钱每年,最先输入的是N和K,你有N的金钱,要求K年后你能得到的最多的金钱数

解析:这个就是普通的完全背包,不过注意的是数值太大,可以投机取巧,因为每中方案中存钱数A是1000的倍数,所以可以背包的下标可以除以1000之后再记录,但是你可能会想到误差问题,比如本金是1010,这时候1010/1000=1,别担心,你想啊,1000和1010存钱有区别么?这10块钱有用么?,存钱方案中都是1000的倍数,所以这些零头都不用管,到时候加上来就行了,我这里的做法是:因为每个利润都小于10%的,所以我去本金X(110%)^K于是得到最大可能的金钱数,用这个数除以1000当作背包的最大容量,DP[X]中装的是存钱为X块的时候的利息,这样我直接完全背包做完之后,再记录sum=N+(N+DP[M])+(N+DP[N]+DP[N+DP[N]]).....这样K次之后就。。。。你会懂的。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Max(a,b) a>b?a:b
using namespace std;
int dp[111111];
struct node
{
    int val,interest;
}s[11];
int main (void)
{
    int t,n,m,i,j,k,l,p;
    scanf("%d",&t);
    while(t--&&scanf("%d%d",&m,&l))
    {
        scanf("%d",&n);
        k=m;
        for(i=0;i<l;i++)
        {
            k=1.1*k;	//用K来取m乘以1.1的L次方
        }
        k/=1000;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&s[i].val,&s[i].interest);
            s[i].val/=1000;	//方案中存钱量除以1000
        }
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)	//直接完全背包
        for(j=s[i].val;j<=k;j++)
        dp[j]=Max(dp[j],dp[j-s[i].val]+s[i].interest);
        while(l>0)	//求l年后的总利息
        {
            l--;
            m+=dp[m/1000];	//把每年的利息加起来并把M变成那一年的本金继续求
        }
        printf("%d\n",m);
    }
    return 0;
}

总结:这是把容量根据条件缩小的一种做法,在做题的时候要根据已知条件充分挖掘一切可以简化的方法,有些时候这题目考的就是这个,就像这题一样,不会这么简化的话,你就等着GG到死吧。。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值