POJ2063-Investment

## 完全背包-动态规划 ##
- 问题链接:【2063】(http://poj.org/problem?id=2063)
- Description

John never knew he had a grand-uncle, until he received the notary’s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.
Assume the following bonds are available:
Value Annual
interest
4000
3000 400
250

With a capital of e10 000 one could buy two bonds of 4000,givingayearlyinterestof 800. Buying two bonds of 3000,andoneof 4 000 is a better idea, as it gives a yearly interest of 900.Aftertwoyearsthecapitalhasgrownto 11 800, and it makes sense to sell a 3000oneandbuya 4 000 one, so the annual interest grows to 1050.Thisiswherethisstorygrowsunlikely:thebankdoesnotchargeforbuyingandsellingbonds.Nextyearthetotalsumis 12 850, which allows for three times 4000,givingayearlyinterestof 1 200.
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.
Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow.
The first line of a test case contains two positive integers: the amount to start with (at most 1000000),andthenumberofyearsthecapitalmaygrow(atmost40).Thefollowinglinecontainsasinglenumber:thenumberd(1<=d<=10)ofavailablebonds.Thenextdlineseachcontainthedescriptionofabond.Thedescriptionofabondconsistsoftwopositiveintegers:thevalueofthebond,andtheyearlyinterestforthatbond.Thevalueofabondisalwaysamultipleof 1 000. The interest of a bond is never more than 10% of its value.
Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.
Sample Input

1
10000 4
2
4000 400
3000 250
Sample Output

14050

  • Analysis
    这是一个完全背包问题(即每一年可以投资无限多的相同的或不同的债券,前提是不超过本金)(请参考完全背包问题),值得注意的是,由于本金的数目太大将致使解数组开到1000000,而债券的价值又是1000的倍数,在这里使用压缩数据的方法,使得数组可以开小一点

  • 源程序

#include <iostream>
#include <cstdio>  
#include <string.h>  
#include <algorithm>  

using namespace std;  

struct Node  
{  
    int v, w;  
}a[12];  

int dp[50000];     //dp[i]:The maximum benefit we can get while the principal is i;

int main()  
{  
    int t, n, pri, y;      //number of case, kind of bond, principal, years
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d%d",&pri,&y);  
        scanf("%d",&n);  
        for(int i = 1; i<=n; i++)  
        {  
            scanf("%d%d",&a[i].v,&a[i].w);  
            a[i].v/=1000;        //compression(压缩) 
        }  
        for(int i = 1;i<=y;i++)  
        {  
            int s = pri/1000;          //Annual principal=principal+interest  
            memset(dp,0,sizeof(dp));        //Reset
            for(int j = 1;j<=n;j++)        //完全背包  
            {  
                for(int k = a[j].v;k<=s;k++) //The money to buy bonds can not exceed the principal; and together/1000
                {  
                    dp[k]=max(dp[k],dp[k-a[j].v]+a[j].w);      //STL function
                }  
            }  
            pri+=dp[s];//Maximum:principal+interest  
        }  
        printf("%d\n",pri);  
    }  

    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值