Modular Inverse

Modular Inverse
Time Limit: 2 Seconds      Memory Limit: 65536 KB
The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).
Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.
Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.
Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".
Sample Input

3
3 11
4 12
5 13
Sample Output

4
Not Exist
8
References

http://en.wikipedia.org/wiki/Modular_inverse
来源: http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712
#include <iostream>
#include <cstdio>
#include <cmath>
typedef long long LL;
using namespace std;
void exgcd(LL a,LL b,LL &x,LL &y,LL &d)
{
    if(!b) { d=a; x=1; y=0;}
    else {exgcd(b,a%b,y,x,d);y-=x*(a/b);}
}
int cal(LL a,LL m)  //! ax=1 (mod m)
{
    LL x,y,gcd;exgcd(a,m,x,y,gcd);
    if(1%gcd) return -1;
    m=abs(m);LL ans=x%m;
    return ans<=0?ans+m:ans;
}
int main(void)
{
    //freopen("D:\\test.txt","r",stdin);  //没注释WA了一次
    int T;scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        LL a,n;scanf("%I64d %I64d",&a,&n);
        int x=cal(a,n);
        if(x<0) cout<<"Not Exist"<<endl;
        else cout<<x<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值