Is the Name of This Problem

The philosopher Willard Van Orman Quine (1908–2000) described a novel method of constructing a sentence in order to illustrate the contradictions that can arise from self-reference. This operation takes as input a single phrase and produces a sentence from that phrase.  (The author Douglas R.Hofstadter refers to this process asto Quine a phrase.) We can de ne the Quine operation like so:

                        Quine(A) ="A" A

In other words, if A is a phrase, then Quine (A) is A enclosed in quotes (" "), followed by a space,followed by A. 

For example:
    Quine(HELLO WORLD) = "HELLO WORLD" HELLO WORLD
    Below are some other examples of sentences that can be created by the Quine operation. Note that Quining allows sentences to be indirectly self-referential, such as the last sentence below.
    "IS A SENTENCE FRAGMENT" IS A SENTENCE FRAGMENT
    "IS THE NAME OF THIS PROBLEM" IS THE NAME OF THIS PROBLEM
    "YIELDS FALSEHOOD WHEN QUINED" YIELDS FALSEHOOD WHEN QUINED
    Your goal for this problem is to take a sentence and decide whether the sentence is the result of a Quine operation.

Input

    The input will consist of a sequence of sentences, one sentence per line, ending with a line that has the single word, `END'. Each sentence will contain only uppercase letters, spaces, and quotation marks.
    Each sentence will contain between 1 and 80 characters and will not have any leading, trailing, or consecutive spaces.
    You must decide whether each sentence is the result of a Quine operation. To be a Quine, a sentence must match the following patternexactly :
    1. A quotation mark
    2. Any nonempty sequence of letters and spaces (call this phrase A )
    3. A quotation mark
    4. A space
    5. Phrase
    A | exactly as it appeared in (2) If it matches this pattern, the sentence is a Quine of the phrase A . Note that phrase A must contain the exact same sequence of characters both times it appears.

Output

There will be one line of output for each sentence in the data set. If the sentence is the result of a Quine operation, your output should be of the form, `Quine(A)', where A is the phrase to Quine to create the sentence.If the sentence is not the result of a Quine operation, your output should be the phrase, ` not aquine'.

Note:

    A review of quotation marks in strings:
    As a reminder, the quotation mark character is a regular character, and can be referred to in C,
    C++, and Java using the standard single-quote notation, like so:'"'
    However, to place a quotation mark inside a double-quoted string in C, C++, and Java, you must place a backslash (n) in front of it. If you do not it will be interpreted as the end of the string, causing syntax errors. 
    For example:
    "This quotation mark \" is inside the string"
    "\""
    "\"SAID SHE\" SAID SHE"

SampleInput

"HELLO WORLD" HELLO WORLD
"IS A SENTENCE FRAGMENT" IS A SENTENCE FRAGMENT
"IS THE NAME OF THIS PROBLEM" IS THE NAME OF THIS PROBLEM
"YIELDS FALSEHOOD WHEN QUINED" YIELDS FALSEHOOD WHEN QUINED
"HELLO" I SAID
WHAT ABOUT "WHAT ABOUT"
" NO EXTRA SPACES " NO EXTRA SPACES
"NO"QUOTES" NO"QUOTES
""
END

SampleOutput

Quine(HELLO WORLD)
Quine(IS A SENTENCE FRAGMENT)
Quine(IS THE NAME OF THIS PROBLEM)
Quine(YIELDS FALSEHOOD WHEN QUINED)
not a quine
not a quine
not a quine
not a quine
not a quine

一道水题,唯一注意的是要判断 二次引用 /“ ,还有一定得是( ” )开头的 ”A“ A,中间还得有空格(-_-WA了一次才意识到)

#include <cstdio>
#include <cstring>
using namespace std;
char A[100000],B[100000],C[100000];
bool Handle(int len)
{
    int Count_B=0,Count_C=0,i;
    if(A[1]!='"') return false;
    for(i=2;i<=len;i++)
    {
        if(A[i]=='"')
        {
            if(A[i-1]!=92)  break;
            else            B[++Count_B] = A[i];
        }
        else if(A[i]==92&&A[i]&&A[i+1]=='"')   continue;
        else B[++Count_B] = A[i];
    }
    if(A[++i]!=' ') return false;
    for(i = i+1;i<=len;i++) C[++Count_C]=A[i];
    B[Count_B+1]=C[Count_C+1]=0; //puts(B+1);puts(C+1);
    if(!Count_B||!Count_C) return false;
    return !strcmp(B+1,C+1);

}
int main(void)
{
    //freopen("E:\\test.txt","r",stdin);
    while(gets(A+1)!=NULL)
    {
        if(!strcmp("END",A+1)) break;
        bool flag = Handle(strlen(A+1));
        if(flag)   printf("Quine(%s)\n",C+1);
        else        printf("not a quine\n");
    }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值