HDU 4463 kruskal 水题

Outlets
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3165    Accepted Submission(s): 1471


Problem Description
In China, foreign brand commodities are often much more expensive than abroad. The main reason is that we Chinese people tend to think foreign things are better and we are willing to pay much for them. The typical example is, on the United Airline flight, they give you Haagendazs ice cream for free, but in China, you will pay $10 to buy just a little cup.
So when we Chinese go abroad, one of our most favorite activities is shopping in outlets. Some people buy tens of famous brand shoes and bags one time. In Las Vegas, the existing outlets can't match the demand of Chinese. So they want to build a new outlets in the desert. The new outlets consists of many stores. All stores are connected by roads. They want to minimize the total road length. The owner of the outlets just hired a data mining expert, and the expert told him that Nike store and Apple store must be directly connected by a road. Now please help him figure out how to minimize the total road length under this condition. A store can be considered as a point and a road is a line segment connecting two stores.


Input
There are several test cases. For each test case: The first line is an integer N( 3 <= N <= 50) , meaning there are N stores in the outlets. These N stores are numbered from 1 to N. The second line contains two integers p and q, indicating that the No. p store is a Nike store and the No. q store is an Apple store. Then N lines follow. The i-th line describes the position of the i-th store. The store position is represented by two integers x,y( -100<= x,y <= 100) , meaning that the coordinate of the store is (x,y). These N stores are all located at different place. The input ends by N = 0.


Output
For each test case, print the minimum total road length. The result should be rounded to 2 digits after decimal point.


Sample Input

4
2 3
0 0
1 0
0 -1 
1 -1
0



Sample Output

3.41



Source
2012 Asia Hangzhou Regional Contest


Recommend
We have carefully selected several similar problems for you:  5733 5732 5731 5730 5729 

感触良多,本来这是一道kruskal水题,但是WA*n ,交叉测试后才发现是强制转换浮点哪里出来问题,可能是qsort出错,可能是其他的错误,AC和WA都放在下面,等qsort再练熟一点看看是怎么回事

//AC:
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <cmath>
using namespace std;
#define MAXN 100
#define MAXN_E 500000   //边可能很多

struct P
{
    int X, Y;
}Point[MAXN * 2];
struct A_Edge_B
{
    int A, B;    //A->B
    int length; //Cost
}Edge[MAXN_E];
int k;
int Par[MAXN], Rank[MAXN];
void Init(int n)
{
    for (int i = 1;i <= n;i++)
    {
        Par[i] = i;
        Rank[i] = 0;
    }
}
int Find(int x)
{
    if (Par[x] == x) return x;
    else return Par[x] = Find(Par[x]);
}
void Unite(int x, int y)
{
    x = Find(x);y = Find(y);
    if (x == y) return;
    if (Rank[x]<Rank[y]) Par[x] = y;
    else Par[y] = x;
    if (Rank[x] == Rank[y]) Rank[x]++;
}
int cmp(const void *a, const void *b)
{
    A_Edge_B *c, *d;
    c = (A_Edge_B *)a;
    d = (A_Edge_B *)b;
    return c->length - d->length;
}
double Cal_Len(int a,int b)//a->b
{
    int dX = Point[a].X  - Point[b].X;
    int dY = Point[a].Y  - Point[b].Y;
    return dX * dX + dY * dY;
}
double Handle(int n)
{

    int Nike, Apple;
    double ans;
    Init(n);
    scanf("%d%d", &Nike, &Apple);
    for (int i = 1;i<=n;i++)    scanf("%d%d", &Point[i].X, &Point[i].Y);
    k = 0;
    for (int i = 1;i<=n;i++)
        for (int j = 1;j<=i;j++)
        {
            k++;
            Edge[k].A = i;
            Edge[k].B = j;
            Edge[k].length = Cal_Len(i,j);
        }
    qsort(Edge+1, k, sizeof(Edge[0]),cmp);
    ans = sqrt((double)Cal_Len(Nike,Apple));
    Unite(Nike, Apple);
    for (int i = 1;i<=k;i++)
    {
        int Pa = Find(Edge[i].A);
        int Pb = Find(Edge[i].B);
        if (Pa == Pb)    continue;
        Unite(Pa, Pb);
        ans += sqrt((double)Edge[i].length);
    }
    return ans;
}
int main()
{
   // freopen("F:\\test.txt", "r", stdin);
    int n;
    while (~scanf("%d", &n) && n)
        printf("%.2lf\n", Handle(n));
    return 0;
}
//WA
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <cmath>
using namespace std;
#define MAXN 100
#define MAXN_E 500000   //边可能很多
int Par[MAXN], Rank[MAXN];
struct P
{
    int X, Y;
}Point[MAXN * 2];
struct A_Edge_B
{
    int A, B;    //A->B
    double length; //Cost
}Edge[MAXN_E];
int k;
void Init(int n)
{
    for (int i = 1;i <= n;i++)
    {
        Par[i] = i;
        Rank[i] = 0;
    }
}
int Find(int x)
{
    if (Par[x] == x) return x;
    else return Par[x] = Find(Par[x]);
}
void Unite(int x, int y)
{
    x = Find(x);y = Find(y);
    if (x == y) return;
    if (Rank[x]<Rank[y]) Par[x] = y;
    else Par[y] = x;
    if (Rank[x] == Rank[y]) Rank[x]++;
}
int cmp(const void *a, const void *b)
{
    A_Edge_B *c, *d;
    c = (A_Edge_B *)a;
    d = (A_Edge_B *)b;
    return c->length - d->length >=0? 1:0;
}
double Cal_Len(int a,int b)//a->b
{
    int dX = Point[a].X  - Point[b].X;
    int dY = Point[a].Y  - Point[b].Y;
    return sqrt(double(dX * dX + dY * dY));
}
double Handle(int n)
{

    int Nike, Apple;
    double ans;
    Init(n);
    scanf("%d%d", &Nike, &Apple);
    for (int i = 1;i<=n;i++)    scanf("%d%d", &Point[i].X, &Point[i].Y);
    k = 0;
    for (int i = 1;i<=n;i++)
        for (int j = 1;j<=i;j++)
        {
            k++;
            Edge[k].A = i;
            Edge[k].B = j;
            Edge[k].length = Cal_Len(i,j);
        }
    qsort(Edge+1, k, sizeof(Edge[0]),cmp);
    ans = Cal_Len(Nike,Apple);
    Unite(Nike, Apple);
    for (int i = 1;i<=k;i++)
    {
        int Pa = Find(Edge[i].A);
        int Pb = Find(Edge[i].B);
        if (Pa == Pb)    continue;
        Unite(Pa, Pb);
        ans += Edge[i].length;
    }
    return ans;
}
int main()
{
    //freopen("F:\\test.txt", "r", stdin);
    int n;
    while (~scanf("%d", &n) && n)
        printf("%.2lf\n", Handle(n));
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值