uva1639 Candy 数学期望 对数处理精度

1639 Candy


LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy
boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first
box with probability p and the second box with probability (1 − p). For the chosen box, if there are
still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no
candy left. Before opening the other box, he wants to know the expected number of candies left in the

other box. Can you help him?


Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2×10 5 ) and a real number
p (0 ≤ p ≤ 1, with 6 digits after the decimal).

Input is terminated by EOF.


Output
For each test case, output one line ‘Case X: Y ’ where X is the test case number (starting from 1)
and Y is a real number indicating the desired answer.

Any answer with an absolute error less than or equal to 10 −4 would be accepted.


Sample Input
10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520

2276 0.720000


Sample Output
Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816

Case 6: 1390.500000



参考紫书333页,方法同样

P(ξ=K)= C(n,k) * p^k * (1-p)^(n-k), 其中C(n, k) = n!/(k! * (n-k)!)

得出第i次打开盒子1没糖的概率C(2n-1,n)p^(n+1)(1-p)^(n-i)
得出第i次打开盒子2没糖的概率C(2n-1,n)(1-p)^(n+1)p^(n-i)
第i次打开盒子没有糖的概率就为上述两式相加,根据期望公式每次与i相乘求和则为总期望



#include<cmath>
#include<cstdio>
using namespace std;
typedef long double LD;
const int MAX = 2*1e5+5;
LD logF[2*MAX];

LD logC(int n,int m){ //计算C(n,m)的对数 In(C(n,m))
    return logF[n]-logF[m]-logF[n-m];
}

int main()
{
    for(int i=1;i<=400005;++i) logF[i]=logF[i-1]+log(i); //预处理In(n!)

    int n,cas=1;double p;
    while(scanf("%d%lf",&n,&p)==2)
    {
        double ans=0.0;
        for(int i=1;i<=n;i++){
            LD c=logC(2*n-i,n);
            LD v1=c+(n+1)*log(p)+(n-i)*log(1-p);
            LD v2=c+(n+1)*log(1-p)+(n-i)*log(p);
            ans+=i*(exp(v1)+exp(v2));
        }
        printf("Case %d: %f\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值