hdu1541树状数组

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2067    Accepted Submission(s): 791


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5  1 1  5 1  7 1  3 3  5 5
 

Sample Output

  
  
1  2  1  1  0

题意:

题目意思就是说,给你一张star maps,每个star有自己的level,level是这样计算的:(Let the level of a star be an amount of the stars that are not higher and not to the right of the given star.)统计这个star左下角star的个数,就是这个star的level。现在要你总计图中level从0到N-1的star分别有多少个?

题目输入描述中明确告诉我们,输入的坐标是按Y的升序、如果Y相等,则按X的升序。所以我们发现我们可以完全忽略Y,只要统计小于本身X的star个数,就是level了。现在我们用一个数组a[]统计X坐标为i的个数(增加一个既a[i]++;);同时对每个star计算的得level。


从当前开始 在没加入一个数 比如5 这时候5的高度肯定是最高的顶多有和他高度相同的 (因为按y的升序输入)这时候就可以用树状数组求出数组位置为5和其之前的和了 (5之前的数组元素存的是坐标小于5的星星个数) 先计算后加入该点


#include<stdio.h>
#include<string.h>
int ans[32010+100];
int c[32010+100],n;
int Lowbit(int k)
{
    return k&(-k);
}
void update(int pos,int num)
{
     while(pos<32010)//千万注意这个地方 是32010 不是n 因为n是输入的个数 而不是数组的大小
     {
         c[pos]+=num;
         pos+=Lowbit(pos);
     }
}
int sum(int pos)
{
    int s=0;
    while(pos>0)
    {
        s+=c[pos];
        pos-=Lowbit(pos);
    }
    return s;
}
int main()
{
    int i,x,y;
    while(scanf("%d",&n)!=EOF)
    {
         memset(c,0,sizeof(c));
         memset(ans,0,sizeof(ans));
         for(i=1;i<=n;i++)
         {
             scanf("%d %d",&x,&y);
             x++;//注意题目是从0开始的 而0会导致上面的程序陷入死循环 所以把总体都加1
             ans[sum(x)]++;
             update(x,1);
         }
         for(i=0;i<n;i++)
             printf("%d\n",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值