hdu 1496 hash表求表达式的解的个数 2中hash方法

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3356    Accepted Submission(s): 1347


Problem Description
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
  
  
1 2 3 -4 1 1 1 1
 

Sample Output
  
  
39088 0
 

Author
LL
 

Source
 


#include<stdio.h>
#include<string.h>
int hash[2000000];
int main()
{
     int a,b,c,d,i,j,ans;
	 while(scanf("%d %d %d %d",&a,&b,&c,&d)!=EOF)
	 {
		 if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
		 {
			 printf("0\n");continue;
		 }
		 ans=0;
		 memset(hash,0,sizeof(hash));
		 for(i=1;i<=100;i++)
			 for(j=1;j<=100;j++)
				 hash[1000000+a*i*i+b*j*j]++;//若a b 为正 则 c d其中有负数 那么用100000一减结果和这里的小标一样
		 for(i=1;i<=100;i++)
			 for(j=1;j<=100;j++)
				 ans+=hash[1000000-c*i*i-d*j*j];
	     printf("%d\n",ans*16);//由于每个xi都可能为正或为负 因为是平方 所以其实有16倍我们找到的答案
	 }
	 return 0;
}


下面这个方法 我认为应该是更加一般的方法 使用范围更加广泛一些 

/*
*  hash+数学,很好的题 
*  对整数求hash,采用除余法,及线性探测解决冲突 
*  注意:devc++中不能定义全局变量count,它和库函数中的函数名同名了 
*/
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int M = 175447;
int counts[M];
int result[M];
int temp[101];
int hashInt(int s)
{
    int k = s % M;
    if (k < 0) k += M;
    while (counts[k] && result[k]!=s) k = (k + 1) % M;//如果当前对应不为空 且对应的不是s 则继续寻找
    return k;
}

int solve(int a, int b, int c, int d) {
    if (a>0&&b>0&&c>0&&d>0 || a<0&&b<0&&c<0&&d<0) return 0;
    memset(counts, 0, sizeof(counts));
    int s, p, i, j;
    for (i=1; i<101; ++i) {
        for (j=1; j<101; ++j) {
            s = a * temp[i] + b * temp[j];
            p = hashInt(s);
            result[p] = s;//
            ++counts[p];
        }
    }
    int ans = 0;
    for (i=1; i<101; ++i) {
        for (j=1; j<101; ++j) {
            s = -(c * temp[i] + d * temp[j]);
            p = hashInt(s);
            ans += counts[p];
        }
    }
    return ans;
}

int main() {
    int a, b, c, d;
    for (int i=1; i<101; ++i) temp[i] = i * i;
    while (scanf("%d%d%d%d", &a, &b, &c, &d) != EOF) {
        int ans = solve(a, b, c, d);
        printf ("%d\n", ans<<4);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值