hdu 2576 数论好题 求前n项和的前n项和

Another Sum Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1110    Accepted Submission(s): 292


Problem Description
FunnyAC likes mathematics very much. He thinks mathematics is very funny and beautiful.When he solved a math problem he would be very happy just like getting accepted in ACM.Recently, he find a very strange problem.Everyone know that the sum of sequence from 1 to n is n*(n + 1)/2. But now if we create a sequence which consists of the sum of sequence from 1 to n. The new sequence is 1, 1+ 2, 1+2+3, .... 1+2+...+n. Now the problem is that what is the sum of the sequence from1 to 1+2+...+n .Is it very simple? I think you can solve it. Good luck!
 

Input
The first line contain an integer T .Then T cases followed. Each case contain an integer n (1 <= n <= 10000000).
 

Output
For each case,output the sum of first n items in the new sequence. Because the sum is very larger, so output sum % 20090524.
 

Sample Input
  
  
3 1 24 56
 

Sample Output
  
  
1 2600 30856
 

Source
 

Recommend
lcy

题意 :
已知        1     2     3     4    5     6      7     8     9 。。。。n
前n项和  1    3      6   10   15   21
求x           1    4      10   20  35  56
输入n  输出x    即求前n项和的前n项和

思路:
假设x=sn
则 sn-sn-1=n(n+1)/2; s1=1;
求sn的通项公式  通过累加法  之后化简 可求得公式为Sn = n(n+1)(n+2)/6;

对sn求余 我们可以分成2部分    即n(n+1)   和  (n+2)
注意 本题中要保证n(n+1)(n+2)能被6整除  因为sn一定是个整数
所以求余的时候要这样求余
s1 = (n(n+1))% (20090524*6);
余数里包含6是保证后面的式子可以被6整除。
s2 = (s1*(n+2)/6)%20090524;


另外本题有个坑爹的地方就是输入只能用I64d 不能用lld  否则就错
by hnust_xiehonghao

#include <iostream>
 #include <cstdio>
 
 using namespace std;
 
 int main()
 {
     int t;
     scanf("%d",&t);
     while(t--)
     {
         long long n;
         scanf("%I64d",&n);
         if(n == 1)
         {
             printf("1\n");
             continue;
         }
         long long ans = (n*(n+1))%(20090524*6);
         ans = (ans*(n+2)/6)%20090524;
         printf("%lld\n",ans);
     }
     return 0;
 }





累加法:利用求通项公式的方法称为累加法。累加法是求型如的递推数列通项公式的基本方法



 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值