hdu 2222 ac自动机入门题 可以做模板

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25141    Accepted Submission(s): 8224


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

Author
Wiskey
 

Recommend
lcy
 
 
 
 
建议不了解ac自动机的 请看看
 
题意:

题意:给出n个串,然后给一篇文章,问这n个串有多少个在文章里面出现过。。。

trick:n个串可能有相同的,需按照不同串处理。

 
#include<stdio.h>
#include<string.h>
#include<malloc.h>
#include<queue>
using namespace std;
char str[1000000+100];

struct node
{
    int count;
    struct node *next[26];
    struct node *fail;
    void init()
    {
        int i;
        for(i=0;i<26;i++)
            next[i]=NULL;
        count=0;
        fail=NULL;
    }
}*root;
void insert()
{
    int len,k;
    node *p=root;
    len=strlen(str);
    for(k=0;k<len;k++)
    {
        int pos=str[k]-'a';
        if(p->next[pos]==NULL)
        {
            p->next[pos]=new node;
            p->next[pos]->init();
            p=p->next[pos];
        }
        else 
            p=p->next[pos];
    }
    p->count++;
}
void getfail()
{
    int i;
       node *p=root,*son,*temp;
       queue<struct node *>que;
       que.push(p); 
       while(!que.empty())
       {
           temp=que.front();
           que.pop();
           for(i=0;i<26;i++)
           {
               son=temp->next[i];
               if(son!=NULL)
               {
                   if(temp==root) {son->fail=root;}
                   else
                   {
                       p=temp->fail;
                       while(p)
                       {
                           if(p->next[i])
                           {
                               son->fail=p->next[i];
                               break;
                           }
                           p=p->fail;
                       }
                       if(!p)  son->fail=root;
                   }
                   que.push(son);
               }
           }
       }
}
void query()
{
    int len,i,cnt=0;
    len=strlen(str);
    node *p,*temp;
    p=root;
    for(i=0;i<len;i++)
    {
        int pos=str[i]-'a';
        while(!p->next[pos]&&p!=root)  p=p->fail;      
        p=p->next[pos];//
        if(!p) p=root;//
        temp=p;
        /*不要用*temp=*p  因为*p表示一个node,而*temp也表示一个node 但是由于*temp没有分配空间 所以是不能进行赋值的 但是可以用temp指针去指向p*/
        while(temp!=root)
        {
            if(temp->count>=0) 
            {
                cnt+=temp->count;
                temp->count=-1;  
            }
            else break; 
            temp=temp->fail; 
        }
    }
    printf("%d\n",cnt);
}
int main()
{
    int cas,n;
    scanf("%d",&cas);
    while(cas--)
    {
        root=new node;
        root->init();
        root->fail=NULL;
        scanf("%d",&n);
        int i;
        getchar();
        for(i=0;i<n;i++)
        {
            gets(str);
            insert();
        }
        getfail();
        gets(str);
        query();
    }
    return 0;
}

 
 
 
  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值