hdu 4311 Meeting point-1 递推 多校联合赛(二) 第二题 好题

Meeting point-1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2537    Accepted Submission(s): 791


Problem Description
It has been ten years since TJU-ACM established. And in this year all the retired TJU-ACMers want to get together to celebrate the tenth anniversary. Because the retired TJU-ACMers may live in different places around the world, it may be hard to find out where to celebrate this meeting in order to minimize the sum travel time of all the retired TJU-ACMers.
There is an infinite integer grid at which N retired TJU-ACMers have their houses on. They decide to unite at a common meeting place, which is someone's house. From any given cell, only 4 adjacent cells are reachable in 1 unit of time.
Eg: (x,y) can be reached from (x-1,y), (x+1,y), (x, y-1), (x, y+1).
Finding a common meeting place which minimizes the sum of the travel time of all the retired TJU-ACMers.
 


 

Input
The first line is an integer T represents there are T test cases. (0<T <=10)
For each test case, the first line is an integer n represents there are n retired TJU-ACMers. (0<n<=100000), the following n lines each contains two integers x, y coordinate of the i-th TJU-ACMer. (-10^9 <= x,y <= 10^9)
 


 

Output
For each test case, output the minimal sum of travel times.
 


 

Sample Input
  
  
4 6 -4 -1 -1 -2 2 -4 0 2 0 3 5 -2 6 0 0 2 0 -5 -2 2 -2 -1 2 4 0 5 -5 1 -1 3 3 1 3 -1 1 -1 10 -1 -1 -3 2 -4 4 5 2 5 -4 3 -1 4 3 -1 -2 3 4 -2 2
 


 

Sample Output
  
  
26 20 20 56
Hint
In the first case, the meeting point is (-1,-2); the second is (0,0), the third is (3,1) and the last is (-2,2)
 


 

Author
TJU
 


 

Source

转载自http://blog.csdn.net/youngyangyang04/article/details/7798252

 

题意:

给定n个坐标,求其中一个坐标到其他坐标曼哈顿距离之和的最小值。

 

 

思路:

x,y分开算,排序之后就是在x轴上可以分别算出每个点到其他距离和sumx,y轴上可以分别算出每个点到其他距离和sumy,对于询问的(x,y),可以二分查找到他在x轴上对应的sumx,y轴上对应sumy,在sumx+sumy就ok啦!!

至于我们怎么找算sumx,sumy,如果挨个算那就又是n^2啦,不好,想一个办法,就是递推先算出第一个点到说有点的距离sumx[1],然后就递推了,因为我们想右递推的过程中,里右面的点越来越进,左面的点越来越远,sumx[i]向sum[i+1]移动,远了左面点的个数*a[i+1]-a[i](从小到大排序的),近了右面点的个数*a[i+1]-a[i],所以递推公式为sumx[i]=sumx[i-1]-(long long)(m-i)*(a[i]-a[i-1])+(long long)i*(a[i]-a[i-1]);注意中间会溢出的

 

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define N 100005
long long sumx[N],sumy[N];
int a[N],b[N],aa[N],bb[N],m;
long long find1(int x)
{
    int l=0,r=m-1;
    while(r>=l){
        int mid=(l+r)>>1;
        if(x>a[mid])
            l=mid+1;
        if(x<a[mid])
            r=mid-1;
        if(x==a[mid])
            return sumx[mid];
    }
    return sumx[l];
}
long long find2(int x)
{
    int l=0,r=m-1;
    while(r>=l){
        int mid=(l+r)>>1;
        if(x>b[mid])
            l=mid+1;
        if(x<b[mid])
            r=mid-1;
        if(x==b[mid])
            return sumy[mid];
    }
    return sumy[l];
}
int main()
{
    int n,x,y;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
            aa[i]=a[i];
            bb[i]=b[i];
            sumx[i]=sumy[i]=0;
        }
        sort(a,a+m);
        sort(b,b+m);
        for(int i=1;i<m;i++){
            sumx[0]+=a[i]-a[0];
            sumy[0]+=b[i]-b[0];
        }
        for(int i=1;i<m;i++){
            sumx[i]=sumx[i-1]-(long long)(m-i)*(a[i]-a[i-1])+(long long)i*(a[i]-a[i-1]);
            sumy[i]=sumy[i-1]-(long long)(m-i)*(b[i]-b[i-1])+(long long)i*(b[i]-b[i-1]);
        }

        long long sum,min1=300000000000000LL;
        for(int i=0;i<m;i++){
            sum=find1(aa[i])+find2(bb[i]);
            if(sum<min1)
                min1=sum;
        }
        cout<<min1<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值