关于HDU1000的几个我所了解到的问题

Problem Description
Calculate A + B.
Input
Each line will contain two integers A and B. Process to end of file.
Output
For each case, output A + B in one line.
Sample Input
1 1
Sample Output

2

直接贴上代码:

#include<iostream>

using namespace std;

int main()
{
	int a,b;
	while(cin>>a>>b)
	{
		cout<<a+b<<endl;
	}
	return 0;
}
初学者可能存在如下疑问:

cin>>a>>b的返回值是多少?否则while语句怎么将其作为判断条件呢?

key:c++中,cin是对象,没有所谓的返回值,而cin可以作为判断条件的机理是if语句可以直接判断流,而while可以间接判断流,当成功输入时,条件为真。

PS:我是在xp下的vc6写的,结束使用ctrl+x操作的,而并不是ctrl+z。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值