数据结构实验之查找三:树的种类统计
Time Limit: 400MS
Memory Limit: 65536KB
Problem Description
随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。
Input
输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。
Output
按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。
Example Input
2 This is an Appletree this is an appletree
Example Output
this is an appletree 100.00%
Hint
Author
xam
#include<bits/stdc++.h>
#include<stdlib.h>
#include<stdlib.h>
using namespace std;
struct node
{
char data[21];
int num;
node *l, *r;
}Tree;
{
char data[21];
int num;
node *l, *r;
}Tree;
int n;
node *creat(node *root, char *a)
{
if(!root)
{
root = new node;
strcpy(root -> data, a);
root -> num = 1;
root -> l = root -> r = NULL;
}
else
{
int t = strcmp(root -> data, a);
if(t < 0)
{
root -> r = creat(root -> r, a);
}
else if(t > 0)
{
root -> l = creat(root -> l, a);
}
else
{
root -> num += 1;
}
}
return root;
}
{
if(!root)
{
root = new node;
strcpy(root -> data, a);
root -> num = 1;
root -> l = root -> r = NULL;
}
else
{
int t = strcmp(root -> data, a);
if(t < 0)
{
root -> r = creat(root -> r, a);
}
else if(t > 0)
{
root -> l = creat(root -> l, a);
}
else
{
root -> num += 1;
}
}
return root;
}
void zhong(node *root)
{
if(root)
{
zhong(root -> l);
printf("%s %.2lf%%\n", root -> data, 100.0 * root -> num / n);//写的时候把100.0写成了100,耽误了好久。。。
zhong(root -> r);
}
}
{
if(root)
{
zhong(root -> l);
printf("%s %.2lf%%\n", root -> data, 100.0 * root -> num / n);//写的时候把100.0写成了100,耽误了好久。。。
zhong(root -> r);
}
}
int main()
{
char a[21];
scanf("%d", &n);
getchar();
node *root = NULL;
for(int i = 0; i < n; i++)
{
gets(a);
for(int j = 0; a[j] != '\0'; j++)
{
if(a[j] >= 'A' && a[j] <= 'Z')
a[j] = a[j] + 32;
}
root = creat(root, a);
}
zhong(root);
return 0;
}
{
char a[21];
scanf("%d", &n);
getchar();
node *root = NULL;
for(int i = 0; i < n; i++)
{
gets(a);
for(int j = 0; a[j] != '\0'; j++)
{
if(a[j] >= 'A' && a[j] <= 'Z')
a[j] = a[j] + 32;
}
root = creat(root, a);
}
zhong(root);
return 0;
}