入栈出栈代码实现以及相关例题

了解更多栈的知识,请点击 

#include<stdio.h>
#include<iostream>
typedef struct node{
 int date;
 node * next;
}SeqStack ;
SeqStack * init_SeqStack(SeqStack * top){
 top=NULL;
 return top;
}
int is_Empty(SeqStack * top){
 if(top==NULL)return 1;
 else return 0;
}
SeqStack * push_Stack(SeqStack * top){
  SeqStack * New;
  New=(SeqStack *)malloc(sizeof(SeqStack));
  printf("请输入要入栈的元素\n");
  scanf("%d",&New->date);
  New->next=top;
  top=New;
  return top;
}
SeqStack * pop_Stack(SeqStack * top,int &m){
 SeqStack * p=NULL;
 if(!is_Empty(top)){ 
  m=top->date;
  p=top;
  top=top->next;
  free(p);
  return top; 
 }
}
SeqStack * top_Stack(SeqStack * top,int &m){
 if(!is_Empty(top)){
  m= top->date;
  return top;
 }
}
int main(){
 int m=0;
 SeqStack * s=NULL;
 init_SeqStack(s);
 s=push_Stack(s);
 s=push_Stack(s);
 s=push_Stack(s);
 s=push_Stack(s);
 s=top_Stack(s,m);
 printf("%d\n",m);
 s=top_Stack(s,m);
 printf("%d\n",m);
 s=pop_Stack(s,m);
 printf("%d\n",m);
 s=top_Stack(s,m);
 printf("%d\n",m);
 if(is_Empty(s)) printf("栈现在是空了");
 system("pause");
 return 0;
}

//顺序栈的初始化,建立,插入,查找,删除。  //

//Author:Wang Yong                 //   

//Date: 2010.8.19                  //

 

 

#include <stdio.h>

#include <stdlib.h>

 

#define  MAX 100                //定义最大栈容量

 

typedef int ElemType;

 

///

 

//定义栈类型

typedef struct

{

    ElemType data[MAX];

    int top;

}SeqStack;

 

///

 

//栈的初始化

 

SeqStack SeqStackInit()

{

    SeqStack s;

    s.top = -1;

    return s;

}

 

///

 

//判断栈空的算法

 

int SeqStackIsEmpty(SeqStack s)

{

    if(s.top == -1)

        return 0;

    else

        return 1;

}

 

///

 

//进栈的算法

 

void SeqStackPush(SeqStack &s,ElemType x)

{

    if(s.top == MAX-1)              //进栈的时候必须判断是否栈满

        printf("stack full\n");

    s.top++;

    s.data[s.top] = x;

}

 

//

 

//出栈的算法

 

ElemType SeqStackPop(SeqStack &s)

{

    if(s.top == -1)             //出栈的时候必须判断是否栈空

        printf("stack empty\n");

    ElemType x;

    x = s.data[s.top];

    s.top--;

    return x;

}

 

//

int main()

{

    SeqStack  stack;

    stack = SeqStackInit();

    printf("请输入进栈的元素:");

    ElemType x;

    while(scanf("%d",&x) != -1)

    {

        SeqStackPush(stack,x); 

    }

    printf("出栈的结果:");

    while(stack.top != -1)

    {

        printf("%d ",SeqStackPop(stack));

    }

    printf("\n");

    return 0;

}

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

 


\begin{picture}(6774,3429)(0,-10)\put(1789.500,1357.500){\arc{3645.278}{4.7247}......tFigFont{14}{16.8}{\rmdefault}{\mddefault}{\updefault}Station}}}}}\end{picture}

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has $N \leŸ 1000$ coaches numbered in increasing order $1, 2, \dots, N$. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be $a_1. a_2, \dots, a_N$. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

 

Input 

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer  N described above. In each of the next lines of the block there is a permutation of  $1, 2, \dots, N$ The last line of the block contains just 0.

The last block consists of just one line containing 0.

 

Output 

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

 

Sample Input 

 

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

 

Sample Output 

 

Yes
No

Yes

分析

题意:给定一串连续的数,放入一个栈中,看接收的数据能否按照某种顺序输出,eg:1 2 3 4 5---->5 4 3 2 1

两种思路:

  • 考虑栈为空     先把1,2,…n放入栈中,直到等于输入的数a[i],n出栈,以此类推,如果最后栈为空,证明放入栈中的n个数字已经都被清空,则这组数据可以按照某种顺序输出      ***每次输入数据后一定要清空栈,否则不AC
  • 考虑出栈的个数     两种思路差不多,考虑出栈的个数可以看看入栈的1,2,…n出栈的数字有多少

考虑栈为空  

#include<cstdio>
#include<stack>

using namespace std;
const int MAXN=1010;

int n,a[MAXN];
int main() {
	while(~scanf("%d",&n)&&n!=0) {//火车量
		stack<int> s;
		int flag;
	
		while(~scanf("%d",&a[0])&&a[0]!=0) {//车厢序号不能为0
			while(!s.empty())s.pop();

			for(int i=1; i<n; i++) {    //多加了= 
				scanf("%d",&a[i]);
			}
		    flag=1;
			for(int i=0;i<n;i++) {
				if(!s.empty()&&s.top()==a[i]) {
					s.pop();
				}else {
					for(int j=flag;j<=n;j++) {
						s.push(j);//入栈 
						flag++;
						if(s.top()==a[i]) {
							s.pop();//出栈 
							break;
						}
					}
				}
			}
			printf("%s\n",s.empty()?"Yes":"No");
		}
		printf("\n"); 
	}
	return 0;
}

考虑出栈的个数  

#include<cstdio>
#include<stack>
using namespace std;
const int MAXN=1000+10;

int n,a[MAXN];
int main() {
	while(~scanf("%d",&n)&&n!=0) {//火车量
		stack<int> s;
	
	
		while(~scanf("%d",&a[0])&&a[0]!=0) {//车厢序号不能为0
			for(int i=1; i<n; i++) {    //多加了= 
				scanf("%d",&a[i]);
			}
			int flag=0,j=0;  
			for(int i=1;i<=n;i++) {
				s.push(i);
				while(!s.empty()&&a[j]==s.top()){
					s.pop();
				    flag++;
				    j++;
				} 
			}
			printf("%s\n",flag==n?"Yes":"No");
		}
		printf("\n"); 
	}
	return 0;
}

 

  • 5
    点赞
  • 45
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值