HDU 3001 traveling


Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8481    Accepted Submission(s): 2759


Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
  
  
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
  
  
100 90 7
 

题意:n 个 点, m 条边, 走遍 n 个点, 每个点最多走2次, 求最小代价。n <= 10

每个点走两次这个条件貌似很难用,其实转化成3进制数就可以像普通tsp问题那样做了!和普通状压的区别就是多了个预处理,也不能直接用位运算而已

#include <cstdio>
#include <string.h>
#define min(a, b) ((a) < (b) ? (a) : (b))
int f[15][60005], three[14], dig[60005][15];
int mp[105][105];
void pre(){
	int i, j, s = 1, t;
	three[0] = 1;
	for(i = 1; i <= 11; i++) three[i] = three[i-1] * 3;
	for(i = 1; i < 59049; i++)
		for(t = i, j = 0; j < 10; j++) dig[i][j] = t % 3, t /= 3;
}
int main(){
	int i, j, n, m, a, b, c, ans, k;
	pre(); 
	while(scanf("%d%d", &n, &m) != EOF){
		ans = 2e9;
		memset(mp, 0, sizeof(mp));
		memset(f, 120, sizeof(f));
		for(i = 1; i <= n; i++) f[i][three[i-1]] = 0;
		for(i = 1; i <= m; i++){
			scanf("%d%d%d", &a, &b, &c);
			if(!mp[a][b]) mp[a][b] = mp[b][a] = c;
			else if(mp[a][b] > c) mp[a][b] = mp[b][a] = c;
		}
		for(i = 1; i < three[n]; i++)
			for(j = 0; j < n; j++) if(dig[i][j] && f[j+1][i] < 2e9)
				for(k = 0; k < n; k++)
					if(mp[j+1][k+1] && dig[i][k] < 2) f[k+1][i+three[k]] = min(f[k+1][i+three[k]], f[j+1][i] + mp[j+1][k+1]);
		for(i = 1; i < three[n]; i++){
			for(j = 0; j < n; j++) if(!dig[i][j]) break;
			if(j == n){
				for(j = 0; j < n; j++) ans = min(ans, f[j][i]);
			}
		}
		if(ans < 2e9) printf("%d\n", ans);
		else printf("-1\n");
	}
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值