hdu-oj 1335 Basically Speaking

Basically Speaking

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2336    Accepted Submission(s): 889


Problem Description

The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.
Its buttons will include the capital letters A through F in addition to the digits 0 through 9.
It will support bases 2 through 16. 
 Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
 Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display.
 Sample Input
  
  
1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15
 Sample Output
  
  
120 78 1765 7CA ERROR 11001 12D687 D071

题目大意:输入一组数据,分别表示:要处理的数,该数的进制,要转换成的进制。

解题思路:定义字符串输入第一个数(里面包含字符),判断字符串的长度,从字符串高位即数字的低位开始转换为10进制,加在一起得sum,

然后将其转换为需要的进制数,注意A-----F代表10--------15;

注意:输出的结果共7位(包含空格)。

附代码:

#include <stdio.h>
#include <string.h>
//#include <math.h>
int main()
{ char s[10],arr[10];
  int i,j,k,m,t,a,b,x;
  long int n;
   while(scanf("%s%d%d",s,&a,&b)!=EOF){
       m=strlen(s);n=0;x=1;
       for(i=m-1;i>=0;i--){
        if(s[i]>='0'&&s[i]<='9')
            k=s[i]-'0';
        else
           switch(s[i]){             
				case 'A':k=10;break;
				case 'B':k=11;break;
				case 'C':k=12;break;
				case 'D':k=13;break;
				case 'E':k=14;break;
				case 'F':k=15;break;
           }
           //n+=(k*(long int)pow(a,m-i-1));
           n+=k*x;x*=a;
       }
       if(n==0) {printf("      0\n");continue;}
		i=0;
		while(n)
		{ //printf("%d\n",n);
			t=n%b;
			if(t>=0&&t<=9)
				arr[i]=t+'0';
			else
				switch(t){
				case 10:{arr[i]='A';break;}
				case 11:{arr[i]='B';break;}
	            case 12:{arr[i]='C';break;}
				case 13:{arr[i]='D';break;}
			    case 14:{arr[i]='E';break;}
				case 15:{arr[i]='F';break;}
			}
			n=n/b;
			i++;
		}
        if(i>7)
		printf("  ERROR");
		else
		{
			for(j=0;j<7-i;j++)
				printf(" ");
			i=i-1;
			for(;i>=0;i--)
				printf("%c",arr[i]);
		}
		printf("\n");
        memset(s,'\0',sizeof(s));
        memset(arr,'\0',sizeof(arr));                                   
   }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值