hdu-oj 1563 Find your present!

Find your present!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2690    Accepted Submission(s): 1785


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
  
  
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
  
  
3 2
 

方法很多:(1)查找,数组设为499999超时了!ac不了!

(2)you can assume that only one number appear odd times.根据这句话可以想想更高效的算法,思考中……

(3)用异或运算符

异或运算符的用法:

整数的异或是先把它们化成二进制,再按位异或。比如3^5,     3=011,5=101,两数按位异或后为 110,即6。       几个数异或满足交换律。2^3^2=2^2^3=0^3=3.       两个相同的数异或为0,普通数都出现了偶数次,所以它们异或后都是0,而0与那个特别数异或后还是那个特殊数。

#include<stdio.h>
//异或运算的运用
int main()
{
    int t,a,sum;
    while(scanf("%d",&t)&&t!=0)
    {
        scanf("%d",&sum);
        t--;
        while(t--)
        {
            scanf("%d",&a);
            sum^=a;
        }
        printf("%d\n",sum);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值