hdu 1003 maxsum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
看到题,没细想,上去就用了 O(n2) ,结果超时;
 O(n2) 算法  超时 
#include<stdio.h>
  int main()
    {
    	int n;
    	int m;
    	int i;
    	int j;
    	int sum;
    	int max;
    	int beg;
    	int end;
    	int t;
    	int l;
    	int s=0;
    	int a[100010];
    	scanf("%d",&n);
    	   l=n;
      while(n--)
        { t=1;
		s++; 
		  max=-1100;
          scanf("%d",&m);
        for(i=1;i<=m;i++)
          scanf("%d",&a[i]);
            for(i=1;i<=m;i++)
              {  sum=0;
              	for(j=i;j<=m;j++)
              	   {
              	   	sum+=a[j];
              	   	  if(sum>max)
              	   	    {
              	   	      beg=i;
              	   	      max=sum;
              	   	      end=j;
              	   	    	
              	   	    }
              	   }
              }
           printf("Case %d:\n",t++);
           printf("%d %d %d\n",max,beg,end);
     if(s!=l)  printf("\n");
        }
        return 0;
    }
 
 
O(n) 算法
#include<stdio.h>
  int main()
  {
       	int n;
       	int m;
       	int i;
       	int beg;
       	int end;
       	int k=0;
       	int l;
       	int max;
       	int biaoji;
       	int bian;
       	int a[100010];
    scanf("%d",&n);
         l=n;
       while(n--)
     {   k++;
           scanf("%d",&m);
        	for(i=1;i<=m;i++)
        	  scanf("%d",&a[i]);
            max=bian=a[1];
			biaoji=beg=end=1;
		 for(i=2;i<=m;i++)
		  {
		  	 if(bian+a[i]<a[i])   //前面的加上之后变小,直接不要
			    {
				 bian=a[i];  //从下一个开始加
				 biaoji=i;  //标记起始位置 
		        }	
		    
             else
			     {
			     	bian+=a[i];
			     } 
			  //加完之后;需要与最大的进行比较
			 if(bian>max)   //此时就不用再加了,到此终止,最大值,调换, 
			     {                   //  留下始终位置 
				    max=bian;
					beg=biaoji;
					end=i; 
                 }
          }
      printf("Case %d:\n",k);
         printf("%d %d %d\n",max,beg,end);
           if(k!=l)  printf("\n");
     }  
       return 0;
     
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值