HDU1247--Hat’s Words【STL--map】

23 篇文章 0 订阅

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8718    Accepted Submission(s): 3136


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 
题意:按字典序输入一系列单词,输入结束后,判断哪些单词是由其余两个单词连接而成。若是,则输出(输出也按字典序)。
map+string,第一次用string的构造函数,百度了许多,就了解点了皮毛,用string果然精简,好省事啊。
关于string的构造函数,不懂的朋友可以看这里:
http://www.aichengxu.com/view/14112

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <map>
using namespace std;

map <string,int> m;
string str[50010];

int main (){
    int i=-1;
    while(cin>>str[++i]){
        m[str[i]]=1;
    }
    int n=i;
    for(i=0;i<=n;++i){
        int len=str[i].size()-1;
        for(int j=1;j<len;++j){
            string s1(str[i],0,j);//将字符串str中,起始位置为0,长度为j的部分赋值给s1
            string s2(str[i],j);  //将字符串str中,位置j以后的部分(包括j)赋值给s2(这里的位置是字符串的的下标)
            if(m[s1]==1 && m[s2]==1){
                cout<<str[i]<<endl;
                break;
            }
        }
    }
    return 0;
}

今天好累,写完这道就睡。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值