HDU 1532--Drainage Ditches【最大流】

44 篇文章 0 订阅

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10440    Accepted Submission(s): 4959


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 

题目大意:

约翰要修建水沟用来排放农场的雨水,该水沟系统是一个网络流,总共有N条边,M个节点。

1是源点,M是汇点。求最大流是多少。


最大流,套Edmond-Karp算法的模板

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#include <algorithm>
#define inf 0x3f3f3f3f
#define maxn 220
using namespace std;

int vis[maxn];//标记在这条路径上当前节点的前驱,同时标记该节点是否在队列
int pre[maxn];//标记从源点到当前节点实际还剩多少流量可用
int map[maxn][maxn];
int n,m;

int BFS(int st,int ed){
    int i,j;
    queue<int>q;
    for(i=1;i<=m;++i)
        vis[i]=-1;
    vis[st]=0;
    pre[st]=inf;
    q.push(st);
    while(!q.empty()){
        int next =q.front();
        q.pop();
        if(next==ed) break;
        for(i=1;i<=m;++i){
            if(i!=st && map[next][i]>0 && vis[i]==-1){
                vis[i]=next;//记录前驱
                pre[i]=min(map[next][i],pre[next]);
                q.push(i);
            }
        }
    }
    if(vis[ed]==-1) return -1;
    else return pre[ed];
}
int EK (int st,int ed){
    int ans;
    int sum=0;
    while((ans=BFS(st,ed))!=-1){
        int k=ed;  //用前驱寻找路径
        while(k!=st){
            int last=vis[k];
            map[last][k]-=ans;//改变正向边的容量
            map[k][last]+=ans;//改变反向边的容量
            k=last;
        }
        sum+=ans;
    }
    return sum;
}

int main (){
    int i,j;
    int a,b,c;
    while(cin>>n>>m){
        memset(map,0,sizeof(map));
        memset(pre,0,sizeof(pre));
        for(i=0;i<n;++i){
            cin>>a>>b>>c;
            if(a==b)
                continue;
            map[a][b]+=c;//可能出现多条同一起点终点的情况
        }
        cout<<EK(1,m)<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值