HDU 3549--Flow Problem【最大流】

44 篇文章 0 订阅

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 9074    Accepted Submission(s): 4265


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 

#include <iostream>
#include <cstring>
#include <queue>
#include <algorithm>
#define inf 0x3f3f3f3f
#define maxn 1100
using namespace std;

int vis[20];
int pre[20];
int map[maxn][maxn];
int n,m;

int BFS(int st,int ed){
    int i,j;
    queue<int>q;
    memset(vis,-1,sizeof(vis));
    vis[st]=0;
    pre[st]=inf;
    q.push(st);
    while(!q.empty()){
        int next =q.front();
        q.pop();
        if(next==ed) break;
        for(i=1;i<=n;++i){
            if(i!=st && map[next][i]>0 && vis[i]==-1){
                vis[i]=next;
                pre[i]=min(map[next][i],pre[next]);
                q.push(i);
            }
        }
    }
    if(vis[ed]==-1) return -1;
    else return pre[ed];
}
int EK (int st,int ed){
    int ans;
    int sum=0;
    int k,last;
    while((ans=BFS(st,ed))!=-1){
        k=ed;
        while(k!=st){
            last=vis[k];
            map[last][k]-=ans;
            map[k][last]+=ans;
            k=last;
        }
        sum+=ans;
    }
    return sum;
}

int main (){
    int t,num=0;
    cin>>t;
    int a,b,c;
    while(t--){
            cin>>n>>m;
        memset(map,0,sizeof(map));
        memset(pre,0,sizeof(pre));
        while(m--){
            cin>>a>>b>>c;
            if(a==b)
                continue;
            map[a][b]+=c;
        }
        cout<<"Case "<<++num<<": "<<EK(1,n)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值