poj 3259--Wormholes 【spfa判负环】

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 35605 Accepted: 13011

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

题目大意:虫洞问题,现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b话费的时间是-c(时间倒流,并且虫洞是单向的),现在问你从某个点开始走,能回到从前。

解题思路:其实给出了坐标,这个时候就可以构成一张图,然后将回到从前理解为是否会出现负权环,用SPFA即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue> 
#include <stack>
#define maxn 1000100
#define INF 0x3f3f3f3f

using namespace std;

struct node {
	int u, v, w, next;
};

node edge[maxn];
int dist[maxn], head[maxn];
int du[maxn];
bool vis[maxn];
int n, m, w, cnt;

void init(){
	cnt = 0;
	memset(head, -1, sizeof(head));
} 

void add(int u, int v, int w){
	edge[cnt] = {u, v, w, head[u]};
	head[u] = cnt++;
}

void SPFA(){
	for(int i = 1; i <= n; ++i){
		dist[i] = INF;
		vis[i] = 0;
		du[i] = 0; 
	}
	queue<int>q;
	q.push(1);
	dist[1] = 0;
	vis[1] = 1;
	du[1] = 1;
	while(!q.empty()){
		int u = q.front();
		q.pop();
		vis[u] = 0;
		for(int i = head[u]; i != -1; i = edge[i].next){
			int v = edge[i].v;
			int w = edge[i].w;
			if(dist[v] > dist[u] + w){
				dist[v] = dist[u] + w;
				if(!vis[v]){
					vis[v] = 1;
					du[v]++;
					if(du[v] > n){
						printf("YES\n");
						return ;
					}
					q.push(v);
				}
			}
		} 
	}
	printf("NO\n");
}

int main (){
	 int T;
	 int a, b ,c;
	 scanf("%d", &T);
	 while(T--){
	 	init();
	 	scanf("%d%d%d",&n, &m, &w);
	 	while(m--){
	 		scanf("%d%d%d", &a,&b,&c);
	 		add(a, b, c);
	 		add(b, a, c);
		 }
		while(w--){
			scanf("%d%d%d", &a, &b, &c);
			add(a, b, -c);
		}
		SPFA();
	 } 
	 return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值