HDU 1386--Play on Words【并查集判连通 + 欧拉路】

21 篇文章 0 订阅
4 篇文章 0 订阅

Play on Words
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10589 Accepted: 3596

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

判断欧拉路是否存在的方法
有向图:图连通,有一个顶点出度大入度1,有一个顶点入度大出度1,其余都是出度=入度。
无向图:图连通,只有两个顶点是奇数度,其余都是偶数度的。
判断欧拉回路是否存在的方法
有向图:图连通,所有的顶点出度=入度。
无向图:图连通,所有顶点都是偶数度。

思路:每组单词可以构造一个图,图中定点为26个小写字母, 每个单词为图中的一条边,而且图是有向图。


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cstdlib>
#define maxn 110000
using namespace std;

int per[30], in[30], out[30], vis[30];
int M;

void init(){
    for(int i = 0; i < 26; ++i)
        per[i] = i;
    memset(in, 0, sizeof(in));
    memset(out, 0 ,sizeof(out));
    memset(vis, 0 ,sizeof(vis));
}

int find (int x){
    int r = x;
    while(r != per[r])
        r = per[r];
    per[x] = r;
    return r;
}

void join (int a, int b){
    int fa = find(a);
    int fb = find(b);
    if(fa != fb)
        per[fa] = fb;
}

int main(){
    int T;
    char str[1100];
    scanf("%d", &T);
    while(T--){
        scanf("%d", &M);
        init();
        for(int i = 0; i < M; ++i){
            scanf("%s", str);
            int len, u, v;
            len = strlen(str);// u --> v
            u = str[0] - 'a';
            v = str[len - 1] - 'a';
            out[u]++, in[v]++;
            vis[u] = vis[v] = 1;
            join(u, v);
        }
        int ans = 0;
        for(int i = 0; i <= 25; ++i){
            if(per[i] == i && vis[i])
                ans++;
            if(ans > 1)
                break;
        }
        if(ans > 1){
            printf("The door cannot be opened.\n");// 没有构成通路
            continue;
        }
        int st, ed;
        st = ed = 0;
        int flag = 1;
        for(int i = 0; i <26; ++i){
            if(vis[i] && in[i] != out[i]){

                if(in[i] - out[i] == 1)
                    st++;
                else if(out[i] - in[i] == 1)
                    ed++;
                else{
                    flag = 0;
                    break;
                }
            }
        }
        //printf("st = %d, ed = %d\n", st, ed);
        if(flag && st <= 1 && ed <= 1)//st == 0 && ed == 0 是考虑到只有单词只有 aa的这种情况
            printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值