HDOJ5240(sort)(Exam)
Exam
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1071 Accepted Submission(s): 532
Problem Description
As this term is going to end, DRD needs to prepare for his final exams.
DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.
So he wonder whether he can pass all of his courses.
No two exams will collide.
DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.
So he wonder whether he can pass all of his courses.
No two exams will collide.
Input
First line: an positive integer
T≤20
indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n≤105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0≤ri,ei,li≤109 .
There are T cases following. In each case, the first line contains an positive integer n≤105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0≤ri,ei,li≤109 .
Output
For each test case: output ''Case #x: ans'' (without quotes), where
x
is the number of test cases, and
ans
is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).
Sample Input
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
Sample Output
Case #1: NO Case #2: YES
思路: 第i门课需要复习时间 第i门课开考时间 第i门课考试持续时间
ai bi ci
两个限定条件:
1:考第i门课时,必需已花费 ai时间复习了,否则考试失败。即在 bi之前完成第i门课复习.且 bi>(a1+b1)+(a2+b2)+......+(ai-1+bi-1)+ai;
t=(a1+b1)+(a2+b2)+......+(ai-1+bi-1);表示完成前 i-1门考试花费的总时间,再加上第i门课的复习时间 ai,所以在第 i门考试前必须完成以的
工作即 bi>=t+ai;才能正常参加考试。否则考试失败:
ai bi ci
两个限定条件:
1:考第i门课时,必需已花费 ai时间复习了,否则考试失败。即在 bi之前完成第i门课复习.且 bi>(a1+b1)+(a2+b2)+......+(ai-1+bi-1)+ai;
t=(a1+b1)+(a2+b2)+......+(ai-1+bi-1);表示完成前 i-1门考试花费的总时间,再加上第i门课的复习时间 ai,所以在第 i门考试前必须完成以的
工作即 bi>=t+ai;才能正常参加考试。否则考试失败:
2:而且
bi>=bi-1+ci-1,即在i-1门考试期间
(bi-1~~bi-1+ci-1),第i门课不能开考,否则考试失败。
My solution:
/*2015.11.12*/
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
int a,b,c;
}t[100005];
int cmp(node a,node b)
{
return a.b<b.b;
}
int main()
{
int t1,i,j=0,n,m,ans;
scanf("%d",&t1);
while(t1--)
{
j++;
scanf("%d",&n);
t[0].a=0;
t[0].b=0;
t[0].c=0;
for(i=1;i<=n;i++)
scanf("%d%d%d",&t[i].a,&t[i].b,&t[i].c);
sort(t,t+n+1,cmp);/*按考试的先后顺序进行排列*/
for(i=1;i<=n;i++)
{
m=t[i].a+t[i-1].c;
if(t[i].b>=m&&t[i].b>=t[i-1].b+t[i-1].c);
else
break;
}
if(n+1==i)
printf("Case #%d: YES\n",j);
else
printf("Case #%d: NO\n",j);
}
return 0;
}