HDOJ-2053(Switch Game)(规律)

16 篇文章 0 订阅
7 篇文章 0 订阅

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14484    Accepted Submission(s): 8863


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
  
  
1 5
 

Sample Output
  
  
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 
题意:一行上有很多个数字全是0,第i次操作,则m*i(m,i=1,2,3,4.............)的位置上的数字发生转变(即:0变1(或者1变0)),共进行n次操作,最后输出第n个位置上的数字(0或者1)

注:这道题主要考查n的因数有多少个 
  如:
1的因数有:1,t=1
2的因数有:1、2,t=2 
4的因数有:1、2、4,t=3 
7的因数有:1、7,t=2 
8的因数有:1、2、4、8,t=34
9的因数有:1、3、9,t=3 
(t为偶数则输出:0,t为奇数则输出:1)
这里需要注意的是判断:if(m*m!=n) (m=sqrt(n)) 如;9=3*3,而3只能算做一个因数 

My  solution:

/*2016.3.2*/
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,j,n,m,t;
	while(scanf("%d",&n)==1)
	{
		t=0;
		m=sqrt(n);
		for(i=1;i<=m;i++)
		{
			if(n%i==0)
			t++;
		}
		if(n==1)
		printf("1\n");
		else
		{
			if(m*m!=n)//t*=2;t为偶数 
			printf("0\n");
			else//t=2*t-1,t为奇数 
			printf("1\n");
		}	
	}
	return 0;
 } 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值