HDUOJ-1052(poj-2287)(田忌赛马)(贪心)

37 篇文章 0 订阅
3 篇文章 0 订阅

HDUOJ-1052(poj-2287)(田忌赛马)(贪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24864    Accepted Submission(s): 7244


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
 注:思路,解释,参考: http://www.cnblogs.com/anderson0/archive/2011/05/07/2039971.html,这篇题解比较详细。
特别注意当田忌的最快马和齐王的最快马速度相等时,若田忌的最慢马比齐王的最慢马快时,应用田忌的最慢马抵消齐王的最慢马。
如:田忌:4   3
       齐王:4   1
若:4<--->4,平局,3<-->1,田忌赢,最终田忌赢200金币。
起初自己没有考虑到这种情况,每当田忌的最快马比齐王的最快马慢时,就用田忌的最慢马抵消齐王的最快马。
就是这种结果:
3<-->4,田忌输200金币,4<-->1,田忌赢200金币,最终田忌赢得的金币数为0。
起初自己一直没有找到错误原因,直到看到别人的这个测试数据,才发现错在哪了。
比较好的测试数据(之前一直没找到,看了别人的题解才发现了这个测试数据,从而找到自己苦苦寻觅许久却没有找到的错误之处。虽然自己错了,但是找到错误之处,好激动)
2
4 3
4 1
My  solution:
/*2016.3.27*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int x[1010],y[1010];
int main()
{
	int i,j,n,m,h,sum;
	int x_min,x_max,y_min,y_max;
	while(scanf("%d",&n)==1&&n)
	{
		sum=0;
		for(i=1;i<=n;i++)
		   scanf("%d",&x[i]);
		for(j=1;j<=n;j++)
		   scanf("%d",&y[j]);
		sort(x+1,x+n+1);
		sort(y+1,y+n+1);
		x_min=y_min=1;
		x_max=y_max=n;
		while(x_min<=x_max&&y_min<=y_max)
		{
			if(x[x_max]>y[y_max])//1.田忌最快马比齐王最快马快,两者抵消 
			{
				sum+=200;
				x_max--;
				y_max--;
			}
			else if(x[x_max]==y[y_max])//2.田忌最快马和齐王最快马一样快
			{
				if(x[x_min]>y[y_min])//2.(1) 田忌最慢马比齐王最慢马快,两者抵消 
				{
					x_min++;
					y_min++;
					sum+=200;
				}
				else 
				{
					if(x[x_min]<y[y_max])//2.(2)当 x[x_min]==y[y_max],就是平局,不输赢金币(田忌最慢马和齐王最快马一样快) 
					sum-=200;            // 可能是x_min==x_max,说明此时是最后一匹马的比赛,且为平局.也可能不是最后一局,但田忌剩下的马速度都相等 
					y_max--;
					x_min++;
				}	
			}
		    else //x[x_max]<y[y_max]。3.田忌的最快马比齐王最快马慢 
		    //if(x[x_min]<y[y_max])因:田忌的最快马比齐王最快马慢 ,所以一定满足 x[x_min]<y[y_max],绝不可能满足:x[x_min]==y[y_max]
			{
				sum-=200;
				y_max--;
				x_min++; 
			}
		}
		printf("%d\n",sum);
	}
	return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值