寻找大富翁

点击打开链接


浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.
Input
输入包含多组测试用例. 
每个用例首先包含2个整数n(0<n<=100000)和m(0<m<=10),其中: n为镇上的人数,m为需要找出的大富翁数, 接下来一行输入镇上n个人的财富值. 
n和m同时为0时表示输入结束.
Output
请输出乌镇前m个大富翁的财产数,财产多的排前面,如果大富翁不足m个,则全部输出,每组输出占一行.
Sample Input
3 1
2 5 -1
5 3
1 2 3 4 5
0 0
Sample Output
5
5 4 3


 水题,只是要注意优先队列的用法;

代码1:(优先队列)

#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
	int a;
	bool friend operator<(const node x,const node y)
	{
		return x.a<y.a;
	}
};
int main()
{int n,m,k=0;
node a;
priority_queue <node> que;
while(~scanf("%d%d",&n,&m),n)
{ 
 for(int i=0;i<n;i++)
{
scanf("%d",&a);
que.push(a);
}
int j=m;
while(!que.empty())
		{
				node x=que.top();
				que.pop();
				if(j>1)
				printf("%d ",x.a);
				if(j==1)
				printf("%d\n",x.a);
				j--;	
		}
}
	return 0;
}


代码2:
#include<cstdio>
#include<algorithm>
using namespace std;
int a[1000005];
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m),n)
	{
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		sort(a,a+n,cmp);
		if(m>=n)
		for(int i=0;i<n;i++)
		printf("%d%c",a[i],i==n-1?'\n':' ');
		else 
		{
			for(int i=0;i<m;i++)
			printf("%d%c",a[i],i==m-1?'\n':' ');
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值