Wolf and Rabbit (GCD)【HDU】-1222

点击打开链接

                                              Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8811    Accepted Submission(s): 4484


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
  
  
2 1 2 2 2
 

Sample Output
  
  
NO YES
 

Author
weigang Lee
 

Source
 

Recommend
Ignatius.L


题意:GCD运用经典例题,一狼一兔,狼围绕一个均匀分布着n个兔子洞的山转圈,狼每经过m个洞口,就会进入洞中,那么这个洞就是不安全的。问n个洞中,是否存在安全的洞让兔子藏身才能不是可爱的兔子惨遭毒手呢。

解析:如果有公约数(1除外),就会有重复的,即不能遍历完,就输出YES,反之最大公约数为1即(gcd(m,n)==1)的时候,就输出

代码如下:


#include <stdio.h>
int gcd(int a,int b)
	{
		if(b==0)
		return a;
		return 
		gcd (b,a%b);
	}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int m,n;
		scanf("%d %d",&m,&n);
		if(gcd(m,n)==1)
		printf("NO\n");
		else
		printf("YES\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值