Oil Deposits
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 32809 Accepted Submission(s): 19052
Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
Sample Output
0 1 2 2
Source
题意:“*”,表示没有油,或者“@”表示油袋。如果水平,垂直或对角相邻,两个不同的@是相同油层的一部分,找不同油层即(@的种类)
代码如下:
#include <cstdio>
char map[110][110];
int x,y,m,n,num;
int move_x[8]={0,0,-1,1,1,1,-1,-1};
int move_y[8]={1,-1,0,0,-1,1,-1,1};
bool check(int x,int y)
{
if(x<0||x>=m||y<0||y>=n||map[x][y]=='*')
return false;
return true;
}
bool dfs(int x,int y)
{
map[x][y]='*';
for(int i=0;i<8;i++)
{
if(check(x+move_x[i],y+move_y[i]))
{
if(dfs(x+move_x[i],y+move_y[i]))
return true;
}
}
return false;
}
int main()
{
while(scanf("%d%d",&m,&n)!=EOF&&m)
{
for(int i=0;i<m;i++)
{
scanf("%s",map[i]);
}
num=0;
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
if(map[i][j]=='@')
{
dfs(i,j);
num++;
}
}
}
printf("%d\n",num);
}
return 0;
}