1129: Divisibility


StatusIn/OutTIME LimitMEMORY LimitSubmit TimesSolved UsersJUDGE TYPE
stdin/stdout3s8192K1101268Standard

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions:

17 + 5 + -21 + 15 =  16
17 + 5 + -21 - 15 = -14
17 + 5 - -21 + 15 =  58
17 + 5 - -21 - 15 =  28
17 - 5 + -21 + 15 =   6
17 - 5 + -21 - 15 = -24
17 - 5 - -21 + 15 =  48
17 - 5 - -21 - 15 =  18

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.

Input

There are multiple test cases, the first line is the number of test cases.
The first line of each test case contains two integers, N and K (1 ≤ N ≤ 10000, 2 ≤ K ≤ 100) separated by a space.

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

2
4 7
17 5 -21 15
4 5
17 5 -21 15

Sample Output

Divisible
Not divisible

 


This problem is used for contest: 148 

 

这道题目是比赛时候做的,总结一下

比赛时候这道题目没有AC,是因为+,-号打错了,第二天早上拿出来的时候才发现,我哭啊,否则就可以完胜大二的,拿到第一了啊,悲剧。。。。这道题目有几个经验,第一就是对负数的处理上,去摸(K+负数%K)%K,十分完美的驱魔,接着就是对各种情况的判断。最后什么情况下是成立的,也十分讲究的。

 

#include<stdio.h>
#include<string.h>
bool f[10001][101];
int a[10001];
int main()
{
 int n,i,j,k,m,t1,t2;
 freopen("in.txt","r",stdin);
 freopen("out.txt","w",stdout);
 while(scanf("%d",&m)!=EOF)
 {
  while(m--)
  {
   scanf("%d%d",&n,&k);
   for(i=0;i<n;i++)  scanf("%d",&a[i]);
   memset(f,false,sizeof(f));
            f[0][0]=true;
   for(i=1;i<=n;i++)
     for(j=0;j<k;j++)
     {
    if(j-a[i-1]<0) t1=(k+(j-a[i-1])%k)%k;
       else   t1=(j-a[i-1])%k;
    if(j+a[i-1]>0) t2=(j+a[i-1])%k;
       else   t2=(k+(j+a[i-1])%k)%k;
    if(f[i-1][t1]||f[i-1][t2])
       f[i][j]=true;  
     }
   if(f[n][0]) printf("Divisible/n");
       else    printf("Not divisible/n");
  }
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值