Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 8546 | Accepted: 2894 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
1.按照字典序搜索 即有: int dir[8][2]={ {-2,-1},{-2,1}, {-1,-2},{-1,2}, {1,-2},{1,2}, {2,-1},{2,1} }; 这个字典顺序牢记。。。
2.可直接从(1,1)搜索,不成功,则impossible(对于本题可以这样,理论上没做分析呵呵~) 3.看到其他discussion,说要放大数组,不过我一开始就够大了,没考虑
#include<stdio.h>
#include<string.h>
bool visit[50][50],flag;
int b[8]={-2,-2,-1,-1,1,1,2,2},a[8]={-1,1,-2,2,-2,2,-1,1};
int dx[65],dy[65],n,x,y,count1;
void dfs(int sum,int xx,int yy)
{
int i;
if(sum==x*y)
{
for(i=1;i<=sum;i++)
{
printf("%c",dy[i]-1+'A');
printf("%d",dx[i]);
}
printf("/n");
flag=true;
return;
}
for(i=0;i<8&&!flag;i++)
{
if(xx+a[i]>0&&xx+a[i]<=x&&yy+b[i]>0&yy+b[i]<=y&&!visit[xx+a[i]][yy+b[i]]&&!flag)
{
dx[sum+1]=xx+a[i];
dy[sum+1]=yy+b[i];
visit[xx+a[i]][yy+b[i]]=true;
dfs(sum+1,xx+a[i],yy+b[i]);
visit[xx+a[i]][yy+b[i]]=false;
}
}
}
int main()
{
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
while(scanf("%d",&n)!=EOF)
{
count1=0;
while(n--)
{
flag=false;
printf("Scenario #%d:/n",++count1);
memset(visit,false,sizeof(visit));
scanf("%d%d",&x,&y);
dy[1]=1;
dx[1]=1;
visit[1][1]=true;
dfs(1,1,1);
if(!flag) printf("impossible/n");
printf("/n");
}
}
}