2510: Product


StatusIn/OutTIME LimitMEMORY LimitSubmit TimesSolved UsersJUDGE TYPE
stdin/stdout1s16384K382125Standard

There are multiple test cases, the first line of each test case is a integer n. (2<=n<=20) The next line have n integers (every integer in the range [1,1000]). We can divide these n integers into two parts and get the sum of the integers in these two parts, define them as sumA and sumB. Please calc the max number of sumA*sumB and output it in a single line.

Sample Input

3
5 3 7
2
4 9

Sample Output

56
36

Hint

(5,3),(7)  sumA=8  sumB=7  sumA*sumB=56
(5),(3,7)  sumA=5  sumB=10 sumA*sumB=50
(3),(5,7)  sumA=3  sumB=12 sumA*sumB=36
(),(3,5,7) sumA=0  sumB=15 sumA*sumB=0
The max is 56.

 

Problem Source: xwbsw

 


This problem is used for contest: 120 

 

 

#include<stdio.h>
#include<math.h>
using namespace std;
int sum,sum1,sum2,sum3,n,a[20];
void dfs(int depth,int nowsum)

 if(depth==n)
 {
  if(fabs(nowsum-sum3)<fabs(sum1-sum3)) sum1=nowsum;
  return;
 }
 if(nowsum>sum1) return;
 dfs(depth+1,nowsum+a[depth]);
 dfs(depth+1,nowsum);
}
int main()
{
 //freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
 while(scanf("%d",&n)!=EOF)
 {
  sum=0;
  for(int i=0;i<n;i++)
  { 
      scanf("%d",&a[i]);
      sum+=a[i];
  }
  sum3=sum/2;
  sum1=1<<25;
     dfs(0,0);
     sum2=sum-sum1;
  printf("%d/n",sum1*sum2);    
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值