poj 1182 食物链

食物链
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16743 Accepted: 4664

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。  
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。  
有人用两种说法对这N个动物所构成的食物链关系进行描述:  
第一种说法是"1 X Y",表示X和Y是同类。  
第二种说法是"2 X Y",表示X吃Y。  
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。  
1) 当前的话与前面的某些真的话冲突,就是假话;  
2) 当前的话中X或Y比N大,就是假话;  
3) 当前的话表示X吃X,就是假话。  
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。  

Input

第一行是两个整数N和K,以一个空格分隔。  
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。  
若D=1,则表示X和Y是同类。  
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

Source

 

#include<stdio.h>
struct t
{
  int parent,c,bc;
}ani[50005];
int n,k;
void init()
{
    for(int i=1;i<=n;i++)
    {
       ani[i].parent=i;
       ani[i].c=-1;
       ani[i].bc=-1;
    }
}
int getfather(int x)
{
    if(x==-1)  return -1;
    if(x!=ani[x].parent) ani[x].parent=getfather(ani[x].parent);
    return ani[x].parent;
}
int Union(int ta,int tb)
{
    if(ta==-1)  return tb;
    if(tb==-1)  return ta;
    ani[tb].parent=ta;
    return ta;
}
int main()
{
    scanf("%d%d",&n,&k);
    init();
    int count=0;
    while(k--)
    {
        int x,y,c;
        scanf("%d%d%d",&c,&x,&y);
        if(x>n||y>n) { count++;continue;}
        x=getfather(x);
        y=getfather(y);
        int fa=getfather(ani[x].c);
        int fb=getfather(ani[y].c);
        int ea=getfather(ani[x].bc);
        int eb=getfather(ani[y].bc);
        if(x==y){if(c==2) count++;continue;}
        if(fb==x) {count++;continue;}
        if(fa==y){if(c==1) count++;continue;}
        if(c==2)
        {
            int x1=Union(x,eb);
            int x2=Union(y,fa);
            int x3=Union(ea,fb);
            ani[x1].c=x2;
            ani[x1].bc=x3;
            ani[x2].c=x3;
            ani[x2].bc=x1;
            if(x3!=-1)
            {
               ani[x3].c=x1;
               ani[x3].bc=x2;
            }
        }
        else
        if(c==1)
        {
            int x1=Union(x,y);
            int x2=Union(fa,fb);
            int x3=Union(ea,eb);
            ani[x1].c=x2;
            ani[x1].bc=x3;
            if(x2!=-1)
            {
                ani[x2].c=x3;
                ani[x2].bc=x1;
            }
            if(x3!=-1)
            {
                ani[x3].c=x1;
                ani[x3].bc=x2;
            }
        }
      }
    printf("%d/n",count);
    return 0;
}

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值