1325 Machine Schedule //MaxMatch

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5816 Accepted: 2425

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source

 

A,B两台机器构成一个二分图,在之间按照给出的条件连边。这样想,每一个工作其实是由一条边来代表的,那么我们只要用最少的顶点来覆盖所有的边即可。这就是最小覆盖。

接着的话注意模式为0 的点,还有就是注意这是N*M的图,注意GX,GY的范围

 

#include<stdio.h>

#include<string.h>

int map[101][101];

int link[101];

bool used[101];

int gx,gy;

bool find(int t)

{

    for(int i=1;i<gy;i++)

    if(!used[i]&&map[t][i]==1)//n*m额图!

    {

        used[i]=true;

        if(link[i]==-1||find(link[i]))

        {

            link[i]=t;

            return true;

        }

    }

    return false;

}

int MaxMatch()

{

    int ans=0;

    memset(link,-1,sizeof(link));

    for(int i=1;i<gx;i++)//注意数据范围

    {

        memset(used,false,sizeof(used));

        if(find(i))  ans++;

    }

    return ans;

}

int main()

{

    int n,m,k;

    while(scanf("%d",&n)!=EOF)

    {

        if(n==0)  break;

        scanf("%d%d",&m,&k);

        gx=n;gy=m;

        memset(map,0,sizeof(map));

        for(int i=1;i<=k;i++)

        {

            int l,x,y;

            scanf("%d%d%d",&l,&x,&y);

            if(x!=0&&y!=0) map[x][y]=1;

        }

        printf("%d/n",MaxMatch());

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值