Air Raid
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 3329 | Accepted: 1946 |
Description
With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
Input
no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets
The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.
There are no blank lines between consecutive sets of data. Input data are correct.
Output
Sample Input
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3
Sample Output
2 1
Source
这个问题是二分图的最小路径覆盖问题,路径覆盖的定义是:在有向图中找一些路径,使之覆盖了图中的所有顶点,就是任意一个顶点都跟那些路径中的某一条相关联,且任何一个顶点有且只有一条路径与之关联,一个单独的顶点是一条路径……最小路径覆盖就是最少的路径覆盖数.
#include<string.h>
#include<stdio.h>
int usedif[130];
//usedif[i]记录Y顶点子集中编号为i的顶点是否使用,注意Y子集中的最多顶点数为(7-1)*12+12=84
int link[130];//link[i]记录与Y顶点子集中编号为i的顶点相连的X顶点子集中x的编号
int mat[130][130];//mat[i][j]表示顶点i与j之间是否有边
int gx,gy;//gx为X顶点子集中的顶点数目,gy为Y顶点子集中的顶点数目
bool can(int t) //判断X中的顶点t在Y中是否有顶点与之匹配
{
for(int i=1; i<=gy; i++) //注意范围
{
if(usedif[i]==0&&mat[t][i]) //Y中的顶点i未匹配且t与i之间有边
{
usedif[i]=1;
if(link[i]==-1||can(link[i])) //link[i]=-1表示顶点i还未匹配
//can(link[i])表示顶点i已经匹配而现在唯一的路径,就是走到与i节点匹配的顶点link[i]处继续进行匹配
{
link[i]=t;
return true;
}
}
}
return false;
}
int MaxMatch()
{
int num=0;
memset(link,-1,sizeof(link));
for(int i=1; i<=gx; i++) //对X中的每个顶点在Y中寻找与其匹配的顶点,注意范围
{
memset(usedif,0,sizeof(usedif));
if(can(i)) num++;
}
return num;//返回最大匹配数
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n,m;
scanf("%d%d",&n,&m);
gx=n;
gy=n;//不是m!
memset(mat,0,sizeof(mat));
for(int i=1; i<=m; i++)
{
int u,v;
scanf("%d%d",&u,&v);
mat[u][v]=1;
}
printf("%d/n",n-MaxMatch());
}
return 0;
}