3189 Steady Cow Assignment //MaxMatch

Steady Cow Assignment
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2134 Accepted: 730

Description

Farmer John's N (1 <= N <= 1000) cows each reside in one of B (1 <= B <= 20) barns which, of course, have limited capacity. Some cows really like their current barn, and some are not so happy.  

FJ would like to rearrange the cows such that the cows are as equally happy as possible, even if that means all the cows hate their assigned barn.  

Each cow gives FJ the order in which she prefers the barns. A cow's happiness with a particular assignment is her ranking of her barn. Your job is to find an assignment of cows to barns such that no barn's capacity is exceeded and the size of the range (i.e., one more than the positive difference between the the highest-ranked barn chosen and that lowest-ranked barn chosen) of barn rankings the cows give their assigned barns is as small as possible.

Input

Line 1: Two space-separated integers, N and B  

Lines 2..N+1: Each line contains B space-separated integers which are exactly 1..B sorted into some order. The first integer on line i+1 is the number of the cow i's top-choice barn, the second integer on that line is the number of the i'th cow's second-choice barn, and so on.  

Line N+2: B space-separated integers, respectively the capacity of the first barn, then the capacity of the second, and so on. The sum of these numbers is guaranteed to be at least N.

Output

Line 1: One integer, the size of the minumum range of barn rankings the cows give their assigned barns, including the endpoints.

Sample Input

6 4
1 2 3 4
2 3 1 4
4 2 3 1
3 1 2 4
1 3 4 2
1 4 2 3
2 1 3 2

Sample Output

2

Hint

Explanation of the sample:  

Each cow can be assigned to her first or second choice: barn 1 gets cows 1 and 5, barn 2 gets cow 2, barn 3 gets cow 4, and barn 4 gets cows 3 and 6.

Source

还是二分图的多重匹配

因为喜爱值在区间[1,b],所以可以枚举该差值,设最小喜爱值为low,最大喜爱值为high,初始时low=high=1,如果喜爱值在[low,high]的范围内可以将这n头牛以满足题意的方式安排好,那么就增大low值以用来减小差值,而如果没有安排方案,那么就增大high值来寻找新的安排方案.

 

#include<cstdio>
#include<string.h>
int mat[1010][25];
int c[25];
bool usedif[25];
int link[25][1010];
int n,b,low,high;
bool can(int t)
{
    for(int i=1;i<=b;i++)
    if(usedif[i]==0&&mat[t][i]<=high&&mat[t][i]>=low)
    {
        usedif[i]=true;
        if(link[i][0]<c[i])
        {
            link[i][++link[i][0]]=t;
            return true;
        }
        else
        {
            for(int j=1;j<=link[i][0];j++)
            if(can(link[i][j]))
            {
                link[i][j]=t;
                return true;
            }
        }
    }
    return false;
}
bool check()
{
    for(int i=1;i<=b;i++)  link[i][0]=0;
    for(int i=1;i<=n;i++)
    {
        memset(usedif,0,sizeof(usedif));
        if(!can(i))  return false;
    }
    return true;
}
int solve()
{
    low=high=1;
    int ans=1<<25-1;
    while(low<=high&&high<=b)
    {
        if(check())
        {
            if(high-low+1<ans)  ans=high-low+1;
            low++;
        }
        else
        high++;
    }
    return ans;
}
int main()
{
    while(scanf("%d%d",&n,&b)!=EOF)
    {
        for(int i=1;i<=n;i++)
          for(int j=1;j<=b;j++)
          {
              int t;
              scanf("%d",&t);
              mat[i][t]=j;
          }
        for(int i=1;i<=b;i++) scanf("%d",&c[i]);
        printf("%d/n",solve());
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值