Subsequence //2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU

Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 28   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.

Input

There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

Output

For each test case, print the length of the subsequence on a single line.

Sample Input

5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5

Sample Output

5
4

Source

2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU

 

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<math.h>
using namespace std;
#define maxs( a , b ) a>b?a:b
#define mins( a , b ) a>b?b:a
const int MAX_N = 110005;

int d[MAX_N];
int dpmin[MAX_N][25];
int dpmax[MAX_N][25];
int n;

void create_Dpmin(){
     int i , j;
     for( i = 1 ; i <= n ; i++ )
          dpmin[i][0] = d[i];
     for( j = 1 ; j <= log((double)(n+1))/log(2.0) ; j++ ){
          for( i = 1 ; i+(1<<j)-1 <= n ; i++ ){
               dpmin[i][j] = mins( dpmin[i][j-1] , dpmin[i+(1<<(j-1))][j-1] );
          }
     }
}
void create_Dpmax(){
     int i , j;
     for( i = 1 ; i <= n ; i++ )
          dpmax[i][0] = d[i];
     for( j = 1 ; j <= log((double)(n+1))/log(2.0) ; j++ ){
          for( i = 1 ; i+(1<<j)-1 <= n ; i++ ){
               dpmax[i][j] = maxs( dpmax[i][j-1] , dpmax[i+(1<<(j-1))][j-1] );
          }
     }
}

int getmax( int a , int b ){
    int k = (int)(log((double)(b-a+1))/log(2.0));
    return maxs( dpmax[a][k] , dpmax[b-(1<<k)+1][k] );
}

int getmin( int a , int b ){
    int k = (int)(log((double)(b-a+1))/log(2.0));
    return mins( dpmin[a][k] , dpmin[b-(1<<k)+1][k] );
}
void Init()
{
     create_Dpmin();
     create_Dpmax();
}
inline int Max_Min(int a,int b)
{
    return getmax(a,b)-getmin(a,b);
}
int main()
{
    int m,k;
    while(scanf("%d%d%d",&n,&m,&k)==3)
    {
        for(int i = 1 ; i <= n ; i++ )  scanf("%d",&d[i]);
        Init();
        int now=1;
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            int temp=Max_Min(now,i);
            if(temp>=m&&temp<=k)
            {
                int len=i-now+1;
                if(len>cnt) cnt=len;
            }
            else if(temp<m)
            {
                continue;
            }
            else
            {
                now++;
            }
        }
        printf("%d/n",cnt);
    }
    return 0;
}
/*
3 3 4
1 6 3
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值