POJ 1200 Crazy Search //HASH

Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12290 Accepted: 3339

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.  
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.  

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.  

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

 

 

这一题一看就是很大的数据量,从前往后接着比较每个字符串是否出现过。

刚开始我用ELF想HASH字符串,无奈ELF碰撞的太多,而且还要存储下字符串便于比较,餐具啊,这个题的数据量太大,赵超不误

 

就思考了,也看了别人说的用NC进制HASH,易证,可以保持一一对应,而不出现碰撞,这所以只需要一个数组就够了。

完美啊

接着我就从前往后找,更新的时候只需要把前面那个减去加上新加上的那个,再用hash比较,即可

16MS,C++提交,犀利

 

 

#include<stdio.h>
#include<string.h>
const int N=16000010;
char str[N];
bool hash[N];
int a[10000];
int main()
{
    int n,nc;
    while(scanf("%d%d",&n,&nc)==2)
    {
        memset(a,0,sizeof(a));
        memset(hash,0,sizeof(hash));
         scanf("%s",str);
         int l=strlen(str);
         int num=0;
         for(int i=0;i<l;i++)
         {
             if(!a[str[i]])  a[str[i]]=num++;
         }
         int sum=0,t=0,bb=1;
         for(int i=0;i<n;i++) 
                     t=t*nc+a[str[i]];
         if(hash[t]==0)
         {
                 sum++;
                 hash[t]=true;
         }
         for(int i=1;i<n;i++)  bb=bb*nc;
         for(int i=0;i<=l-n-1;i++)
         {
             t=(t-a[str[i]]*bb)*nc+a[str[i+n]];
             if(hash[t]==0)
             {
                 sum++;
                 hash[t]=true;
             }
         }
         printf("%d/n",sum);
    }
    return 0;
}

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值