Aladdin and the Flying Carpet(LightOJ - 1341)

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

题意:
给你矩形的面积(矩形的边长都是正整数),让你求最小的边大于等于b的矩形的个数。

思路:求出每个质因子的个数,然后用唯一分解定理求出它的约数个数。如果b * b > a,那么值一定为0,其余部分可以枚举b。

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e6+1000;
int n;
int cnt=0;
int primes[maxn];
int vis[maxn];
void playtable()
{
    for(int i=2;i<=sqrt(maxn+0.5);i++)
    {
        if(!vis[i])
        {
            for(int j=i*i;j<=maxn;j+=i)
                vis[j]=1;
        }
    }
    for(int i=2;i<=maxn;i++)
        if(!vis[i])   primes[cnt++]=i;
} 
int main()
{
    int T;
    int kase=0;
    playtable();
    scanf("%d",&T);
    while(T--)
    {
        long long a,b;
        scanf("%lld%lld",&a,&b);
        long long x=a;
        if(a<=b*b) 
		{
		printf("Case %d: 0\n",++kase);
		continue;
		}
        long long ans=1;
        for(int i=0;i<cnt&&primes[i]*primes[i]<=a;i++)
        {
            if(a%primes[i]==0)
            {
                long long num=0;
                while(a%primes[i]==0)
                {
                    num++;
                    a/=primes[i];
                }
                ans*=(1+num);
            }
        }
        if(a>1)  
		ans=ans*2;
        ans=ans/2;
        for(long long i=1;i<b;i++)
            if(x%i==0)  
			ans--;
         printf("Case %d: %lld\n",++kase,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值